projects
/
openwrt
/
svn-archive
/
packages.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
6879654
)
prohibit cython of building *.so-files - just use plain python-implementation
author
Mirko Vogt
<mirko@openwrt.org>
Sun, 4 Jan 2009 03:11:33 +0000
(
03:11
+0000)
committer
Mirko Vogt
<mirko@openwrt.org>
Sun, 4 Jan 2009 03:11:33 +0000
(
03:11
+0000)
SVN-Revision: 13851
lang/cython/Makefile
patch
|
blob
|
history
diff --git
a/lang/cython/Makefile
b/lang/cython/Makefile
index bccaec14aecf882493096166d4a68a2305d3dd9c..9ef4f6cf15c5f35bd4ee7fc55774985bfae92e63 100644
(file)
--- a/
lang/cython/Makefile
+++ b/
lang/cython/Makefile
@@
-32,7
+32,8
@@
define Package/cython/description
endef
define Build/Compile
- $(call Build/Compile/PyMod,,install --prefix="$(PKG_INSTALL_DIR)/usr")
+ # <--no-cython-compile> required, otherwise setup.py calls the target-gcc to create so-files which obviously can't be used by <python> on the host system.
+ $(call Build/Compile/PyMod,,install --no-cython-compile --prefix="$(PKG_INSTALL_DIR)/usr")
endef
define Build/InstallDev