apr: clean up the package
authorSebastian Kemper <sebastian_ml@gmx.net>
Mon, 30 Dec 2019 17:52:50 +0000 (18:52 +0100)
committerSebastian Kemper <sebastian_ml@gmx.net>
Mon, 30 Dec 2019 17:52:56 +0000 (18:52 +0100)
- removes '$(FPIC)' and '--without-pic', there is no good reason for
  them being used (also @minfrin mentioned memory footprint implications
  when '--without-pic' is used)
- stops removing aclocal.m4 and build/ltmain.sh (reason of removal of
  these files is not apparent anymore)
- adds PKG_BUILD_PARALLEL:=1

Resolves #10884

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
libs/apr/Makefile

index 89fe9d29261fde429eae59fbce72972dd07380c1..acddf301878d16c61fbeb5dc923d72bc928f9323 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=apr
 PKG_VERSION:=1.6.5
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@APACHE/apr/
@@ -18,8 +18,9 @@ PKG_HASH:=a67ca9fcf9c4ff59bce7f428a323c8b5e18667fdea7b0ebad47d194371b0a105
 PKG_MAINTAINER:=Thomas Heil <heil@terminal-consulting.de>
 PKG_LICENSE:=Apache-2.0
 
+PKG_BUILD_PARALLEL:=1
+
 PKG_FIXUP:=autoreconf
-PKG_REMOVE_FILES:=aclocal.m4 build/ltmain.sh
 
 PKG_INSTALL:=1
 
@@ -33,10 +34,7 @@ define Package/libapr
   URL:=https://apr.apache.org/
 endef
 
-TARGET_CFLAGS += $(FPIC)
-
 CONFIGURE_ARGS += \
-       --without-pic \
        --with-devrandom=/dev/urandom \
        $(call autoconf_bool,CONFIG_IPV6,ipv6)