regulator: bd71837: adobt MFD changes to regulator driver
authorMatti Vaittinen <matti.vaittinen@fi.rohmeurope.com>
Mon, 30 Jul 2018 11:50:08 +0000 (14:50 +0300)
committerMark Brown <broonie@kernel.org>
Mon, 30 Jul 2018 13:24:20 +0000 (14:24 +0100)
MFD part for bd71837 was changed during the review. Clean regulator part to
match changed MFD:
- renamed header file => fix include
- remove unused platdata as also type definition was removed
- Kconfig option for MFD part was changed => fix depends on clause
- Rename Kconfig option for regulators
  As Kconfig option for regulators gets now used (when dependency to MFD is
  satisfied) change it so that it won't require new change when support for
  bd71847 is added.

Signed-off-by: Matti Vaittinen <matti.vaittinen@fi.rohmeurope.com>
Signed-off-by: Mark Brown <broonie@kernel.org>
drivers/regulator/Kconfig
drivers/regulator/Makefile
drivers/regulator/bd71837-regulator.c

index 8233dc7f0a681f832cc086f6a815f7b245acaa41..347351e79b1ed9cb62e8879924a148ecec856169 100644 (file)
@@ -180,9 +180,9 @@ config REGULATOR_BCM590XX
          BCM590xx PMUs. This will enable support for the software
          controllable LDO/Switching regulators.
 
-config REGULATOR_BD71837
+config REGULATOR_BD718XX
        tristate "ROHM BD71837 Power Regulator"
-       depends on MFD_BD71837
+       depends on MFD_ROHM_BD718XX
        help
          This driver supports voltage regulators on ROHM BD71837 PMIC.
          This will enable support for the software controllable buck
index b7839f41591e6d3d2e2799cf05c21457512ff090..18bfed61e7fe6138ef77141a86b6ab3f45782e03 100644 (file)
@@ -27,7 +27,7 @@ obj-$(CONFIG_REGULATOR_AS3711) += as3711-regulator.o
 obj-$(CONFIG_REGULATOR_AS3722) += as3722-regulator.o
 obj-$(CONFIG_REGULATOR_AXP20X) += axp20x-regulator.o
 obj-$(CONFIG_REGULATOR_BCM590XX) += bcm590xx-regulator.o
-obj-$(CONFIG_REGULATOR_BD71837) += bd71837-regulator.o
+obj-$(CONFIG_REGULATOR_BD718XX) += bd71837-regulator.o
 obj-$(CONFIG_REGULATOR_BD9571MWV) += bd9571mwv-regulator.o
 obj-$(CONFIG_REGULATOR_DA903X) += da903x.o
 obj-$(CONFIG_REGULATOR_DA9052) += da9052-regulator.o
index 3a487255482c13073f031e16113b3d91c44a1008..0f8ac8dec3e16a21e066e9f76318d14ec6c9d78f 100644 (file)
@@ -7,7 +7,7 @@
 #include <linux/gpio.h>
 #include <linux/interrupt.h>
 #include <linux/kernel.h>
-#include <linux/mfd/bd71837.h>
+#include <linux/mfd/rohm-bd718x7.h>
 #include <linux/module.h>
 #include <linux/platform_device.h>
 #include <linux/regulator/driver.h>
@@ -490,7 +490,6 @@ struct reg_init {
 static int bd71837_probe(struct platform_device *pdev)
 {
        struct bd71837_pmic *pmic;
-       struct bd71837_board *pdata;
        struct regulator_config config = { 0 };
        struct reg_init pmic_regulator_inits[] = {
                {
@@ -558,7 +557,6 @@ static int bd71837_probe(struct platform_device *pdev)
                goto err;
        }
        platform_set_drvdata(pdev, pmic);
-       pdata = dev_get_platdata(pmic->mfd->dev);
 
        /* Register LOCK release */
        err = regmap_update_bits(pmic->mfd->regmap, BD71837_REG_REGLOCK,
@@ -578,9 +576,6 @@ static int bd71837_probe(struct platform_device *pdev)
 
                desc = &pmic->descs[i];
 
-               if (pdata)
-                       config.init_data = pdata->init_data[i];
-
                config.dev = pdev->dev.parent;
                config.driver_data = pmic;
                config.regmap = pmic->mfd->regmap;