cyrus-sasl: fix compilation with GCC14
authorRosen Penev <rosenp@gmail.com>
Fri, 17 May 2024 04:14:33 +0000 (21:14 -0700)
committerRosen Penev <rosenp@gmail.com>
Wed, 22 May 2024 00:59:42 +0000 (17:59 -0700)
Missing time.h header.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
libs/cyrus-sasl/Makefile
libs/cyrus-sasl/patches/010-gcc14.patch [new file with mode: 0644]

index b39d46c2573964c549b83358c5192da6d9c5f35b..ae036b5b2f652c66a36aa5c730f20ffc41de8061 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=cyrus-sasl
 PKG_VERSION:=2.1.28
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
 
diff --git a/libs/cyrus-sasl/patches/010-gcc14.patch b/libs/cyrus-sasl/patches/010-gcc14.patch
new file mode 100644 (file)
index 0000000..0ef2dad
--- /dev/null
@@ -0,0 +1,32 @@
+--- a/lib/saslutil.c
++++ b/lib/saslutil.c
+@@ -59,9 +59,7 @@
+ #ifdef HAVE_UNISTD_H
+ #include <unistd.h>
+ #endif
+-#ifdef HAVE_TIME_H
+ #include <time.h>
+-#endif
+ #include "saslint.h"
+ #include <saslutil.h>
+--- a/plugins/cram.c
++++ b/plugins/cram.c
+@@ -48,6 +48,7 @@
+ #include <string.h>
+ #include <stdlib.h>
+ #include <stdio.h>
++#include <time.h>
+ #ifndef macintosh
+ #include <sys/stat.h>
+ #endif
+--- a/plugins/digestmd5.c
++++ b/plugins/digestmd5.c
+@@ -50,6 +50,7 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>
++#include <time.h>
+ #ifndef macintosh
+ #include <sys/types.h>
+ #include <sys/stat.h>