fail2ban: Override Build/Compile instead of Py3Build/Compile
authorJeffery To <jeffery.to@gmail.com>
Mon, 6 Mar 2023 14:07:06 +0000 (22:07 +0800)
committerJeffery To <jeffery.to@gmail.com>
Mon, 24 Apr 2023 08:20:29 +0000 (16:20 +0800)
This allows changes to the Python build system apply more easily to the
package.

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
net/fail2ban/Makefile

index 1d36a36d2202b2585c50b25e21a2ae639b09f9b8..77568e908353674fca8d246125d6ba65b97f53c7 100644 (file)
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=fail2ban
 PKG_VERSION:=0.11.2
-PKG_RELEASE:=7
+PKG_RELEASE:=8
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/fail2ban/fail2ban/tar.gz/$(PKG_VERSION)?
@@ -48,6 +48,11 @@ define Package/fail2ban/conffiles
 /etc/config/fail2ban
 endef
 
+define Build/Compile
+       cd $(PKG_BUILD_DIR) && ./fail2ban-2to3
+       $(call Py3Build/Compile)
+endef
+
 define Py3Package/fail2ban/filespec
 +|$(PYTHON3_PKG_DIR)
 -|$(PYTHON3_PKG_DIR)/fail2ban/tests
@@ -77,11 +82,6 @@ define Py3Package/fail2ban/install
        $(INSTALL_BIN) ./files/fail2ban.defaults $(1)/etc/uci-defaults/99_fail2ban
 endef
 
-define Py3Build/Compile
-       cd $(PKG_BUILD_DIR) && ./fail2ban-2to3
-       $(call Py3Build/Compile/Default)
-endef
-
 $(eval $(call Py3Package,fail2ban))
 $(eval $(call BuildPackage,fail2ban))
 $(eval $(call BuildPackage,fail2ban-src))