dtc: bump to version 1.5.1
authorYousong Zhou <yszhou4tech@gmail.com>
Mon, 16 Sep 2019 00:22:24 +0000 (00:22 +0000)
committerYousong Zhou <yszhou4tech@gmail.com>
Mon, 16 Sep 2019 08:00:19 +0000 (08:00 +0000)
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
libs/dtc/Makefile
libs/dtc/patches/0001-use-cflags-from-build-system.patch [deleted file]
libs/dtc/patches/0002-export-fdt_check_full-and-others.patch [deleted file]

index a806dac197f4b0a18b0f65d9766320827f67e8bb..081eaf0bfbc5cc65955bfc1791dfe4eb1a6b0e4b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2016-2018 Yousong Zhou <yszhou4tech@gmail.com>
+# Copyright (C) 2016-2019 Yousong Zhou <yszhou4tech@gmail.com>
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,10 +8,10 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dtc
-PKG_VERSION:=1.5.0
-PKG_RELEASE:=2
+PKG_VERSION:=1.5.1
+PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_HASH:=c672e443c9f7e39f5a7c8e602da6777f9ad55ad70de87de300a43828c8050172
+PKG_HASH:=660b74039690fc37013660544d09191834efb58503c73c555c5513ba75ab031f
 PKG_SOURCE_URL:=@KERNEL/software/utils/dtc
 PKG_LICENSE:=GPL-2.0
 PKG_LICENSE_FILES:=GPL
@@ -80,6 +80,7 @@ MAKE_FLAGS += \
        NO_PYTHON=1 \
        NO_VALGRIND=1 \
        NO_YAML=1 \
+       EXTRA_CFLAGS=$(EXTRA_CFLAGS) \
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/lib
diff --git a/libs/dtc/patches/0001-use-cflags-from-build-system.patch b/libs/dtc/patches/0001-use-cflags-from-build-system.patch
deleted file mode 100644 (file)
index 15d47c5..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/Makefile.orig    2019-03-15 03:55:48.407966162 +0000
-+++ b/Makefile 2019-03-15 03:56:01.320976021 +0000
-@@ -15,10 +15,10 @@ EXTRAVERSION =
- LOCAL_VERSION =
- CONFIG_LOCALVERSION =
--CPPFLAGS = -I libfdt -I .
-+CPPFLAGS += -I libfdt -I .
- WARNINGS = -Wall -Wpointer-arith -Wcast-qual -Wnested-externs \
-       -Wstrict-prototypes -Wmissing-prototypes -Wredundant-decls -Wshadow
--CFLAGS = -g -Os $(SHAREDLIB_CFLAGS) -Werror $(WARNINGS)
-+CFLAGS += $(SHAREDLIB_CFLAGS) -Werror $(WARNINGS)
- BISON = bison
- LEX = flex
diff --git a/libs/dtc/patches/0002-export-fdt_check_full-and-others.patch b/libs/dtc/patches/0002-export-fdt_check_full-and-others.patch
deleted file mode 100644 (file)
index bef8c10..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-From eac2ad495b29f15d78daa2a7226653f36515cd7a Mon Sep 17 00:00:00 2001
-From: David Gibson <david@gibson.dropbear.id.au>
-Date: Mon, 25 Mar 2019 14:52:47 +1100
-Subject: [PATCH] Update version.lds again
-
-Yet again, we've added several functions to libfdt that were supposed
-to be exported, but forgotten to add them to the versio.lds script.
-This adds them.
-
-Signed-off-by: David Gibson <david@gibson.dropbear.id.au>
----
- libfdt/version.lds | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/libfdt/version.lds b/libfdt/version.lds
-index 9f5d708..a5fe62d 100644
---- a/libfdt/version.lds
-+++ b/libfdt/version.lds
-@@ -66,6 +66,10 @@ LIBFDT_1.2 {
-               fdt_resize;
-               fdt_overlay_apply;
-               fdt_get_string;
-+              fdt_get_max_phandle;
-+              fdt_check_full;
-+              fdt_setprop_placeholder;
-+              fdt_property_placeholder;
-       local:
-               *;
- };