netio: fix passing our CFLAGS to the Makefile
authorFlorian Fainelli <florian@openwrt.org>
Sat, 8 Mar 2014 00:57:29 +0000 (00:57 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 8 Mar 2014 00:57:29 +0000 (00:57 +0000)
Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 39821

net/netio/Makefile
net/netio/patches/001-Makefile.patch

index 48373829fa44fa61a840b9bf3a6d84cb4330bc5b..28fb4be07fcd9223c7154f1e5d83e410be2900b2 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=netio
 PKG_VERSION:=1.31
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)$(subst .,,$(PKG_VERSION)).zip
 PKG_SOURCE_URL:=http://www.ars.de/ars/ars.nsf/f24a6a0b94c22d82862566960071bf5a/aa577bc4be573b05c125706d004c75b5/%24FILE/
@@ -30,7 +30,7 @@ define Package/netio
 endef
 
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) linux CC="$(TARGET_CC)"
+       $(MAKE) -C $(PKG_BUILD_DIR) linux CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS) -DUNIX"
 endef
 
 define Package/netio/install
index caaaf95a5499dc52bb3c1e0571776bd09d50c4df..ba8c0477c432ba014741d9c4402a27801b8e48e6 100644 (file)
@@ -1,11 +1,13 @@
---- a/Makefile         2011-01-17 17:15:11.000000000 +0100
-+++ b/Makefile         2010-10-14 15:03:42.000000000 +0200
-@@ -84,7 +84,7 @@
+--- a/Makefile
++++ b/Makefile
+@@ -84,8 +84,8 @@ solaris:
        $(MAKE) all CC="gcc -O -s" O=.o X= \
        CFLAGS="-DUNIX" LFLAGS="" LIBS="-lsocket -lpthread -lnsl" OUT=-o
  linux:
 -      $(MAKE) all CC="gcc -O -s" O=.o X= \
+-      CFLAGS="-DUNIX" LFLAGS="" LIBS="-lpthread" OUT=-o
 +      $(MAKE) all CC="$(CC) -O -s" O=.o X= \
-       CFLAGS="-DUNIX" LFLAGS="" LIBS="-lpthread" OUT=-o
++      LFLAGS="" LIBS="-lpthread" OUT=-o
  macosx:
        $(MAKE) all CC="gcc -O" O=.o X= \
+       CFLAGS="-DUNIX -DSOCKLEN_T" LFLAGS="" LIBS="-lpthread" OUT=-o