mtd: nand: Get rid of comments giving the file path inside the file itself
authorBoris Brezillon <boris.brezillon@bootlin.com>
Mon, 5 Feb 2018 22:01:59 +0000 (23:01 +0100)
committerBoris Brezillon <boris.brezillon@bootlin.com>
Fri, 16 Feb 2018 09:08:27 +0000 (10:08 +0100)
Some files add a comment giving the path of the file inside the Linux
tree, which is pretty useless since the reader had to find the file to
open it.

Getting rid of these comments will also allow us to easily move these
files around when needed.

Signed-off-by: Boris Brezillon <boris.brezillon@bootlin.com>
18 files changed:
drivers/mtd/nand/Makefile
drivers/mtd/nand/ams-delta.c
drivers/mtd/nand/au1550nd.c
drivers/mtd/nand/bf5xx_nand.c
drivers/mtd/nand/cmx270_nand.c
drivers/mtd/nand/cs553x_nand.c
drivers/mtd/nand/diskonchip.c
drivers/mtd/nand/fsmc_nand.c
drivers/mtd/nand/gpio.c
drivers/mtd/nand/nand_ecc.c
drivers/mtd/nand/orion_nand.c
drivers/mtd/nand/pxa3xx_nand.c
drivers/mtd/nand/s3c2410.c
drivers/mtd/nand/sharpsl.c
drivers/mtd/nand/socrates_nand.c
include/linux/mtd/bbm.h
include/linux/mtd/nand_ecc.h
include/linux/mtd/ndfc.h

index 921634ba400cfa3af1317c4ec35825b74fe5e49a..4e098247626712e2fa7acd05d41d6adcf1468f6c 100644 (file)
@@ -1,7 +1,4 @@
 # SPDX-License-Identifier: GPL-2.0
-#
-# linux/drivers/nand/Makefile
-#
 
 obj-$(CONFIG_MTD_NAND)                 += nand.o
 obj-$(CONFIG_MTD_NAND_ECC)             += nand_ecc.o
index d60ada45c549450758a1079d097b81f56271580d..e15991d81a203d9681bc173b6df331233dc0e2d6 100644 (file)
@@ -1,6 +1,4 @@
 /*
- *  drivers/mtd/nand/ams-delta.c
- *
  *  Copyright (C) 2006 Jonathan McDowell <noodles@earth.li>
  *
  *  Derived from drivers/mtd/toto.c
index 8ab827edf94e2fbc97885032da26105eaeb2bdea..df0ef1f1e2f5f779ec7042e7400033f1fc07b2f8 100644 (file)
@@ -1,6 +1,4 @@
 /*
- *  drivers/mtd/nand/au1550nd.c
- *
  *  Copyright (C) 2004 Embedded Edge, LLC
  *
  * This program is free software; you can redistribute it and/or modify
index 87bbd177b3e55b94f861132fefe8b356de8260de..4a5f56f76efd24d377885a90746127543bc86d66 100644 (file)
@@ -1,5 +1,4 @@
-/* linux/drivers/mtd/nand/bf5xx_nand.c
- *
+/*
  * Copyright 2006-2008 Analog Devices Inc.
  *     http://blackfin.uclinux.org/
  *     Bryan Wu <bryan.wu@analog.com>
index b01c9804590e5d484675a71bc684e99b51929c41..66749ade96545d67f3db787fcd2503bc255a358f 100644 (file)
@@ -1,6 +1,4 @@
 /*
- *  linux/drivers/mtd/nand/cmx270-nand.c
- *
  *  Copyright (C) 2006 Compulab, Ltd.
  *  Mike Rapoport <mike@compulab.co.il>
  *
index d48877540f14477a3892080257a98d87b603e690..be1f28fc736378951811326b568e37146c8806ab 100644 (file)
@@ -1,6 +1,4 @@
 /*
- * drivers/mtd/nand/cs553x_nand.c
- *
  * (C) 2005, 2006 Red Hat Inc.
  *
  * Author: David Woodhouse <dwmw2@infradead.org>
index 6bc93ea66f505a9297b6976f787923eb076e0942..1af77f798fe583d20295d9b0223acf467e2ec7c1 100644 (file)
@@ -1,6 +1,4 @@
 /*
- * drivers/mtd/nand/diskonchip.c
- *
  * (C) 2003 Red Hat, Inc.
  * (C) 2004 Dan Brown <dan_brown@ieee.org>
  * (C) 2004 Kalev Lember <kalev@smartlink.ee>
index f49ed46fa7706c390d1141519a64e5a65c0447e7..e763161a7c823809d0e79123ad02dfc16c759a8e 100644 (file)
@@ -1,6 +1,4 @@
 /*
- * drivers/mtd/nand/fsmc_nand.c
- *
  * ST Microelectronics
  * Flexible Static Memory Controller (FSMC)
  * Driver for NAND portions
index a8bde6665c24f7e20e6103959ceee16c5d3ec5c8..2780af26d9ab7db286d4d17b6c6e2ed165a192a6 100644 (file)
@@ -1,6 +1,4 @@
 /*
- * drivers/mtd/nand/gpio.c
- *
  * Updated, and converted to generic GPIO based driver by Russell King.
  *
  * Written by Ben Dooks <ben@simtec.co.uk>
index 7613a038804435f3b14a7340db00018913ad3a84..3630f0fe8fa447270a6c85ef0753c0737ea43405 100644 (file)
@@ -2,8 +2,6 @@
  * This file contains an ECC algorithm that detects and corrects 1 bit
  * errors in a 256 byte block of data.
  *
- * drivers/mtd/nand/nand_ecc.c
- *
  * Copyright © 2008 Koninklijke Philips Electronics NV.
  *                  Author: Frans Meulenbroeks
  *
index 5a5aa1f07d07477cb9a5e0b88d9309a772e9282e..7825fd3ce66bbb2f590949c653c01b6dea8d20c0 100644 (file)
@@ -1,6 +1,4 @@
 /*
- * drivers/mtd/nand/orion_nand.c
- *
  * NAND support for Marvell Orion SoC platforms
  *
  * Tzachi Perelstein <tzachi@marvell.com>
index d1979c7dbe7ec4e336512513ca7e47af19120435..d75f30263d21e4246c6fd4beaaa0879edd550e9a 100644 (file)
@@ -1,6 +1,4 @@
 /*
- * drivers/mtd/nand/pxa3xx_nand.c
- *
  * Copyright © 2005 Intel Corporation
  * Copyright © 2006 Marvell International Ltd.
  *
index 4c383eeec6f6f74aeb2c5894dd221b6ee41a1b73..b5bc5f106c0930041c6947d465d8917dbb2edbb9 100644 (file)
@@ -1,5 +1,4 @@
-/* linux/drivers/mtd/nand/s3c2410.c
- *
+/*
  * Copyright © 2004-2008 Simtec Electronics
  *     http://armlinux.simtec.co.uk/
  *     Ben Dooks <ben@simtec.co.uk>
index f59c455d9f5170f7749bd7b7a35f4ed7ca1325a6..e93df02c825e319ccc910f53187097e319eebaea 100644 (file)
@@ -1,6 +1,4 @@
 /*
- * drivers/mtd/nand/sharpsl.c
- *
  *  Copyright (C) 2004 Richard Purdie
  *  Copyright (C) 2008 Dmitry Baryshkov
  *
index 575997d0ef8a0d4a64f9fd65d0d299a9105fc029..9824a9923583c453906ae499e18992b8fd096904 100644 (file)
@@ -1,6 +1,4 @@
 /*
- * drivers/mtd/nand/socrates_nand.c
- *
  *  Copyright © 2008 Ilya Yanok, Emcraft Systems
  *
  *
index 3bf8f954b642581c271a7236e8e1b46f6820b015..3102bd754d1882809ce7b74fc6ba7e09bfa7d0c9 100644 (file)
@@ -1,6 +1,4 @@
 /*
- *  linux/include/linux/mtd/bbm.h
- *
  *  NAND family Bad Block Management (BBM) header file
  *    - Bad Block Table (BBT) implementation
  *
index 4d8406c816523e50546e0ef16f0ec8460ecda26c..8a2decf7462c646618d73b2a35556853edd4d73f 100644 (file)
@@ -1,6 +1,4 @@
 /*
- *  drivers/mtd/nand_ecc.h
- *
  *  Copyright (C) 2000-2010 Steven J. Hill <sjhill@realitydiluted.com>
  *                         David Woodhouse <dwmw2@infradead.org>
  *                         Thomas Gleixner <tglx@linutronix.de>
index d0558a9826287e6560491c98b22253b98d44b9a2..357e88b3263a99f0da808a84eed5331e43b590e8 100644 (file)
@@ -1,6 +1,4 @@
 /*
- *  linux/include/linux/mtd/ndfc.h
- *
  *  Copyright (c) 2006 Thomas Gleixner <tglx@linutronix.de>
  *
  * This program is free software; you can redistribute it and/or modify