golang: Update to 1.19.6
authorTianling Shen <cnsztl@immortalwrt.org>
Tue, 21 Feb 2023 04:48:00 +0000 (12:48 +0800)
committerTianling Shen <cnsztl@immortalwrt.org>
Mon, 27 Feb 2023 02:30:16 +0000 (10:30 +0800)
go1.19.6 (released 2023-02-14) includes security fixes to the
crypto/tls, mime/multipart, net/http, and path/filepath packages,
as well as bug fixes to the go command, the linker, the runtime,
and the crypto/x509, net/http, and time packages.

Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
(cherry picked from commit 0cdd7b8c0e7a5461e0a9311734c0cc6cd87aa188)

lang/golang/golang/Makefile

index 0d779064f6707dbdf21a61c04eb80c3e1167e881..26e4c6eeeebf7d441895c05c55dd72868537162b 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 GO_VERSION_MAJOR_MINOR:=1.19
-GO_VERSION_PATCH:=5
+GO_VERSION_PATCH:=6
 
 PKG_NAME:=golang
 PKG_VERSION:=$(GO_VERSION_MAJOR_MINOR)$(if $(GO_VERSION_PATCH),.$(GO_VERSION_PATCH))
@@ -20,7 +20,7 @@ GO_SOURCE_URLS:=https://dl.google.com/go/ \
 
 PKG_SOURCE:=go$(PKG_VERSION).src.tar.gz
 PKG_SOURCE_URL:=$(GO_SOURCE_URLS)
-PKG_HASH:=8e486e8e85a281fc5ce3f0bedc5b9d2dbf6276d7db0b25d3ec034f313da0375f
+PKG_HASH:=d7f0013f82e6d7f862cc6cb5c8cdb48eef5f2e239b35baa97e2f1a7466043767
 
 PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
 PKG_LICENSE:=BSD-3-Clause