sparc: Set DISABLE_BRANCH_PROFILING in VDSO CFLAGS.
authorDavid S. Miller <davem@davemloft.net>
Mon, 22 Oct 2018 05:14:01 +0000 (22:14 -0700)
committerDavid S. Miller <davem@davemloft.net>
Mon, 22 Oct 2018 22:51:45 +0000 (15:51 -0700)
Not in vclock_gettime.c itself.

Signed-off-by: David S. Miller <davem@davemloft.net>
arch/sparc/vdso/Makefile
arch/sparc/vdso/vclock_gettime.c

index dc85570d88395a411842c7d419a0f2d2fb200914..7ea03dd2bd62904c3d6f2fd3808e7d6272d2ae4e 100644 (file)
@@ -58,7 +58,8 @@ CFL := $(PROFILING) -mcmodel=medlow -fPIC -O2 -fasynchronous-unwind-tables \
        -m64 -ffixed-g2 -ffixed-g3 -fcall-used-g4 -fcall-used-g5 -ffixed-g6 \
        -ffixed-g7 $(filter -g%,$(KBUILD_CFLAGS)) \
        $(call cc-option, -fno-stack-protector) -fno-omit-frame-pointer \
-       -foptimize-sibling-calls -DBUILD_VDSO
+       -foptimize-sibling-calls \
+       -DDISABLE_BRANCH_PROFILING -DBUILD_VDSO
 
 $(vobjs): KBUILD_CFLAGS += $(CFL)
 
index 4e853d1582c71ab318f70fec1022e67c6b3091c1..7b5bf63fc0f52e5014547b00f81c4b2938da96a5 100644 (file)
  * Copyright (c) 2017 Oracle and/or its affiliates. All rights reserved.
  */
 
-/* Disable profiling for userspace code: */
-#ifndef        DISABLE_BRANCH_PROFILING
-#define        DISABLE_BRANCH_PROFILING
-#endif
-
 #include <linux/kernel.h>
 #include <linux/time.h>
 #include <linux/string.h>