packages/ffmpeg: disable altivec support
authorGabor Juhos <juhosg@openwrt.org>
Sun, 2 Feb 2014 11:01:50 +0000 (11:01 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sun, 2 Feb 2014 11:01:50 +0000 (11:01 +0000)
The altivec support in the ffmpeg package is enabled
by default which causes the following build error on
powerpc targets:

  You need a compiler that supports {} in AltiVec vector declarations.

  If you think configure made a mistake, make sure you are using the latest
  version from Git.  If the latest version fails, report the problem to the
  ffmpeg-user@ffmpeg.org mailing list or IRC #ffmpeg on irc.freenode.net.
  Include the log file "config.log" produced by configure as this will
  help solving the problem.

Altivec is not supported by any of our powerpc targets, so
disable that by default.

Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 39445

multimedia/ffmpeg/Makefile

index 0808f520dd893a7d3e90349300d5ea25b6184c2d..355410a91893ec4aa715d799ff6a82d436e0486b 100644 (file)
@@ -287,6 +287,7 @@ FFMPEG_CONFIGURE:= \
        --enable-gpl \
        --enable-version3 \
        \
+       --disable-altivec \
        --disable-asm \
        --disable-doc \
        --disable-dxva2 \