shadow-su: ash doesn't support the renaming of a process like
authorPeter Wagner <​tripolar@gmx.at>
Sun, 22 Sep 2013 15:28:04 +0000 (15:28 +0000)
committerPeter Wagner <​tripolar@gmx.at>
Sun, 22 Sep 2013 15:28:04 +0000 (15:28 +0000)
execve("/bin/ash", ["-su"], [/* 10 vars */]) = 0

the error is also described here but no fix is provided

http://comments.gmane.org/gmane.linux.busybox/33618

fix it by turing off process renaming in login.defs

Signed-off-by: Peter Wagner <tripolar@gmx.at>
SVN-Revision: 38121

utils/shadow/Makefile
utils/shadow/patches/001-busybox_ash.patch [new file with mode: 0644]
utils/shadow/patches/002-disable-ruser-lookup.patch [new file with mode: 0644]
utils/shadow/patches/004-disable-ruser-lookup.patch [deleted file]

index fa319252fed8c5efc368334a9f34c391e1d67260..506e5123496116e68a85aa0a82d8766e2b893802 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=shadow
 PKG_VERSION:=4.1.5.1
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://pkg-shadow.alioth.debian.org/releases
diff --git a/utils/shadow/patches/001-busybox_ash.patch b/utils/shadow/patches/001-busybox_ash.patch
new file mode 100644 (file)
index 0000000..f21eee1
--- /dev/null
@@ -0,0 +1,13 @@
+diff --git a/etc/login.defs b/etc/login.defs
+index 5b6fab3..79eeccf 100644
+--- a/etc/login.defs
++++ b/etc/login.defs
+@@ -111,7 +111,7 @@ NOLOGINS_FILE      /etc/nologin
+ # command is "-su".  If not defined, then "ps" would display the
+ # name of the shell actually being run, e.g. something like "-sh".
+ #
+-SU_NAME               su
++#SU_NAME              su
+ #
+ # *REQUIRED*
diff --git a/utils/shadow/patches/002-disable-ruser-lookup.patch b/utils/shadow/patches/002-disable-ruser-lookup.patch
new file mode 100644 (file)
index 0000000..7a6f38e
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/configure.in
++++ b/configure.in
+@@ -195,7 +195,6 @@ AC_DEFINE_UNQUOTED(PASSWD_PROGRAM, "$sha
+ dnl XXX - quick hack, should disappear before anyone notices :).
+ AC_DEFINE(USE_SYSLOG, 1, [Define to use syslog().])
+ AC_DEFINE(RLOGIN, 1, [Define if login should support the -r flag for rlogind.])
+-AC_DEFINE(RUSEROK, 0, [Define to the ruserok() "success" return value (0 or 1).])
+ AC_ARG_ENABLE(shadowgrp,
+       [AC_HELP_STRING([--enable-shadowgrp], [enable shadow group support @<:@default=yes@:>@])],
diff --git a/utils/shadow/patches/004-disable-ruser-lookup.patch b/utils/shadow/patches/004-disable-ruser-lookup.patch
deleted file mode 100644 (file)
index 7a6f38e..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/configure.in
-+++ b/configure.in
-@@ -195,7 +195,6 @@ AC_DEFINE_UNQUOTED(PASSWD_PROGRAM, "$sha
- dnl XXX - quick hack, should disappear before anyone notices :).
- AC_DEFINE(USE_SYSLOG, 1, [Define to use syslog().])
- AC_DEFINE(RLOGIN, 1, [Define if login should support the -r flag for rlogind.])
--AC_DEFINE(RUSEROK, 0, [Define to the ruserok() "success" return value (0 or 1).])
- AC_ARG_ENABLE(shadowgrp,
-       [AC_HELP_STRING([--enable-shadowgrp], [enable shadow group support @<:@default=yes@:>@])],