ptunnel-ng: fix compilation with kernel 5.15
authorRosen Penev <rosenp@gmail.com>
Thu, 31 Mar 2022 03:25:12 +0000 (20:25 -0700)
committerRosen Penev <rosenp@gmail.com>
Thu, 31 Mar 2022 03:29:26 +0000 (20:29 -0700)
Some header change requires to include musl's headers first.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
net/ptunnel-ng/Makefile
net/ptunnel-ng/patches/010-musl.patch [new file with mode: 0644]

index 1513fb7a518b73c2c1b9a89cc92367efccd665fa..95b53d1aaef0eb7df52792a6de27f42510c90c1e 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ptunnel-ng
 PKG_VERSION:=1.42
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/lnslbrty/ptunnel-ng/tar.gz/v$(PKG_VERSION)?
diff --git a/net/ptunnel-ng/patches/010-musl.patch b/net/ptunnel-ng/patches/010-musl.patch
new file mode 100644 (file)
index 0000000..d3a8c5a
--- /dev/null
@@ -0,0 +1,22 @@
+--- a/src/ptunnel.h
++++ b/src/ptunnel.h
+@@ -45,9 +45,6 @@
+ #define PING_TUNNEL_H 1
+ #ifndef WIN32
+-#ifdef HAVE_ICMPFILTER
+-#include <linux/icmp.h>
+-#endif
+ #ifdef HAVE_SYS_UNISTD_H
+ #include <sys/unistd.h>
+ #endif
+@@ -56,6 +53,9 @@
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+ #include <netdb.h>
++#ifdef HAVE_ICMPFILTER
++#include <linux/icmp.h>
++#endif
+ #include <pthread.h>
+ #include <errno.h>
+ #include <net/ethernet.h>