privoxy: fix postinst missing $
authorJosh Powers <powersj@fastmail.com>
Mon, 21 Nov 2022 17:32:37 +0000 (10:32 -0700)
committerRosen Penev <rosenp@gmail.com>
Sat, 26 Nov 2022 10:45:04 +0000 (02:45 -0800)
fixes: #19949

Signed-off-by: Josh Powers <powersj@fastmail.com>
net/privoxy/Makefile

index 6ce0574afb5e56c2f6f2b37c527155545cac2c37..9f859c4eb63670df4be18dca89d114e489f88ece 100644 (file)
@@ -158,7 +158,7 @@ endef
 define Package/privoxy/postinst
        #!/bin/sh
        # if exists, update previous version entry missing protocol
-       (grep -E "privoxy.*8118$" $${IPKG_INSTROOT}/etc/services) > /dev/null \
+       (grep -E "privoxy.*8118$$" $${IPKG_INSTROOT}/etc/services) > /dev/null \
                && sed -i "s/privoxy.*8118/privoxy\t\t8118\/tcp/" $${IPKG_INSTROOT}/etc/services
 
        # add missing tcp and udp entries