python-setuptools: first revision
authorAlexandru Ardelean <aa@ocedo.com>
Wed, 5 Nov 2014 13:50:08 +0000 (15:50 +0200)
committerAlexandru Ardelean <ardeleanalex@gmail.com>
Wed, 12 Nov 2014 22:22:55 +0000 (00:22 +0200)
Signed-off-by: Alexandru Ardelean <aa@ocedo.com>
lang/python-setuptools/Makefile [new file with mode: 0644]

diff --git a/lang/python-setuptools/Makefile b/lang/python-setuptools/Makefile
new file mode 100644 (file)
index 0000000..9187614
--- /dev/null
@@ -0,0 +1,62 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+# 
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-setuptools
+PKG_VERSION:=7.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=setuptools-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://pypi.python.org/packages/source/s/setuptools/
+PKG_MD5SUM:=6245d6752e2ef803c365f560f7f2f940
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/setuptools-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+$(call include_mk, python-package.mk)
+
+define Package/python-setuptools
+  SUBMENU:=Python
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=Tool for installing Python packages.
+  URL:=https://bitbucket.org/pypa/setuptools
+  DEPENDS:=+python
+endef
+
+define Package/python-setuptools/description
+  Easily download, build, install, upgrade, and uninstall Python packages
+endef
+
+PYTHONPATH:=$(PKG_INSTALL_DIR)/$(PYTHON_PKG_DIR)
+define Build/Compile
+       $(INSTALL_DIR) $(PYTHONPATH)
+       $(call Build/Compile/PyMod,,\
+               install --prefix="$(PKG_INSTALL_DIR)/usr" \
+       )
+endef
+
+define PyPackage/python-setuptools/filespec
++|/usr/lib/python$(PYTHON_VERSION)/site-packages
+endef
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(2)/lib/python$(PYTHON_VERSION)/site-packages
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/python$(PYTHON_VERSION)/site-packages/* \
+               $(HOST_PYTHON_LIB_DIR)/site-packages
+endef
+
+define PyPackage/python-setuptools/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
+endef
+
+$(eval $(call PyPackage,python-setuptools))
+$(eval $(call BuildPackage,python-setuptools))
+