include $(TOPDIR)/rules.mk
PKG_NAME:=rdiff-backup
-PKG_VERSION:=1.0.4
+PKG_VERSION:=1.0.5
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://savannah.nongnu.org/download/rdiff-backup/
-PKG_MD5SUM:=756b38aaf2602d097cafd08996fb7887
+PKG_MD5SUM:=fa2a165fa07a94be52c52e3545bc7758
PKG_BUILD_DEPENDS:=python
DEPENDS:=python-core +librsync +libpopt
endef
+define Package/rdiff-backup/description
+ rdiff-backup backs up one directory to another, possibly over a
+ network. The target directory ends up a copy of the source directory,
+ but extra reverse diffs are stored in a special subdirectory of that
+ target directory, so you can still recover files lost some time ago.
+ The idea is to combine the best features of a mirror and an incremental
+ backup.
+endef
+
define PyPackage/rdiff-backup/filespec
+|/usr/bin/rdiff-backup
+|$(PYTHON_PKG_DIR)/rdiff_backup
-diff -urN rdiff-backup-1.0.4/rdiff-backup rdiff-backup-1.0.4.new/rdiff-backup
---- rdiff-backup-1.0.4/rdiff-backup 2006-01-16 05:09:59.000000000 +0100
-+++ rdiff-backup-1.0.4.new/rdiff-backup 2008-05-26 12:14:28.000000000 +0200
+--- a/rdiff-backup
++++ b/rdiff-backup
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/python
# rdiff-backup -- Mirror files while keeping incremental changes
- # Version 1.0.4 released January 15, 2006
+ # Version 1.0.5 released November 11, 2006
# Copyright (C) 2001-2005 Ben Escoto <rdiff-backup@emerose.org>