This patch includes new Makefile for chan-sccp-b V4.1-RC1 compiled against the asteri...
authorJiri Slachta <slachta@cesnet.cz>
Tue, 14 May 2013 16:14:37 +0000 (18:14 +0200)
committerJiri Slachta <slachta@cesnet.cz>
Tue, 14 May 2013 16:14:37 +0000 (18:14 +0200)
Signed-off-by: Diederik de Groot <ddegroot@users.sourceforge.net>
[slachta@cesnet.cz: slightly changed dependencies, removed maintainer variable]
Tested-by: Jiri Slachta <slachta@cesnet.cz>
Signed-off-by: Jiri Slachta <slachta@cesnet.cz>
asterisk-11.x-chan-sccp-b/Makefile [new file with mode: 0644]
asterisk-11.x-chan-sccp-b/files/sccp.openwrt.conf [new file with mode: 0644]

diff --git a/asterisk-11.x-chan-sccp-b/Makefile b/asterisk-11.x-chan-sccp-b/Makefile
new file mode 100644 (file)
index 0000000..1ec852a
--- /dev/null
@@ -0,0 +1,61 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=asterisk11-chan-sccp-b
+PKG_REV=4631
+PKG_VERSION:=r$(PKG_REV)
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://svn.code.sf.net/p/chan-sccp-b/code/trunk
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=$(PKG_REV)
+PKG_SOURCE_PROTO:=svn
+
+PKG_FIXUP:=autoreconf -fi
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/asterisk11-chan-sccp-b
+  SUBMENU:=Telephony
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=SCCP channel provider for asterisk
+  URL:=http://chan-sccp-b.net.sourceforge.net/
+  DEPENDS:= asterisk11 +libltdl
+endef
+
+define Package/asterisk11-chan-sccp-b/description
+ SCCP channel provider for asterisk. It delivers extended functionality for SCCP phones over chan_skinny delivered
+ by asterisk by default.
+endef
+
+define Build/Configure
+    $(call Build/Configure/Default,--with-asterisk=$(STAGING_DIR)/usr/include/asterisk-11)
+endef
+
+define Build/Compile
+       $(MAKE) -C "$(PKG_BUILD_DIR)" \
+               CFLAGS="$(CFLAGS) -I$(PKG_BUILD_DIR)/src -DLOW_MEMORY" \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+endef
+
+define Package/asterisk11-chan-sccp-b/conffiles
+/etc/asterisk/sccp.conf
+endef
+
+define Package/asterisk11-chan-sccp-b/install
+       $(INSTALL_DIR) $(1)/etc/asterisk
+       $(CP)  ./files/sccp.openwrt.conf $(1)/etc/asterisk/sccp.conf
+       $(INSTALL_DIR) $(1)/usr/lib/asterisk/modules
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/asterisk/modules/chan_sccp.so $(1)/usr/lib/asterisk/modules/
+endef
+
+$(eval $(call BuildPackage,asterisk11-chan-sccp-b))
diff --git a/asterisk-11.x-chan-sccp-b/files/sccp.openwrt.conf b/asterisk-11.x-chan-sccp-b/files/sccp.openwrt.conf
new file mode 100644 (file)
index 0000000..c59f4cd
--- /dev/null
@@ -0,0 +1,89 @@
+[general]
+servername = Openwrt
+keepalive = 60
+debug = core
+context = default
+dateformat = D/M/Y
+bindaddr = 192.168.1.1
+port = 2000
+disallow=all
+allow=ulaw
+allow=alaw
+allow=gsm
+firstdigittimeout = 16
+digittimeout = 6
+autoanswer_ring_time = 1
+musicclass=default
+language=en
+deny=0.0.0.0/0.0.0.0
+permit=192.168.1.0/255.255.255.0
+protocolversion=17
+
+hotline_enabled=yes
+hotline_context=default
+hotline_extension=111
+
+[SEP001122334455]
+type = device
+description = Phone Number One
+devicetype = 7940
+button = line, 111
+button = line, 113@01:shared
+button = speeddial,Phone 2 Line 1, 112, 112@hint
+
+[SEP00a1a2a3a4a5]
+type = device
+description = Phone Number Two
+devicetype = 7960
+button = line, 112
+button = line, 113@01:shared
+button = speeddial,Phone 1 Line 1, 111, 111@hint
+
+[111]
+id = 1000
+type = line
+pin = 1234
+label = Phone 1 Line 1
+description = Line 111
+mailbox = 10111
+cid_name = Phone 1 CID
+cid_num = 111
+accountcode=79111
+callgroup=1
+pickupgroup=1
+context = default
+incominglimit = 2
+vmnum = 600
+trnsfvm = 1000
+
+[112]
+id = 1001
+type = line
+pin = 1234
+label = Phone 2 Line 1
+description = Line 112
+mailbox = 10112
+cid_name = Phone 2 CID
+cid_num = 112
+accountcode=79112
+callgroup=1
+pickupgroup=1
+context = default
+incominglimit = 2
+vmnum = 600
+trnsfvm = 1000
+
+[113]
+id = 1002
+type = line
+pin = 1234
+label = SharedLine 1
+description = Line 113
+mailbox = 10113
+cid_name = Shared
+cid_num = 113
+accountcode=79113
+incominglimit = 2
+vmnum = 600
+trnsfvm = 1000
+