projects
/
feed
/
packages.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
f50e2bd
)
protobuf-c: fix host build on GCC4
author
Rosen Penev
<rosenp@gmail.com>
Sun, 24 May 2020 04:16:25 +0000
(21:16 -0700)
committer
Rosen Penev
<rosenp@gmail.com>
Mon, 25 May 2020 01:36:13 +0000
(18:36 -0700)
prereq-build.mk says that GCC 4.8 and above is supported. GCC 4.8
does not default to gnu++11. This fixes compilation.
Signed-off-by: Rosen Penev <rosenp@gmail.com>
libs/protobuf-c/Makefile
patch
|
blob
|
history
diff --git
a/libs/protobuf-c/Makefile
b/libs/protobuf-c/Makefile
index 0a54ea2a64582383482f3f9deb7cccb67a644543..42d48269dc0506f3370cb996f025bda71810c43c 100644
(file)
--- a/
libs/protobuf-c/Makefile
+++ b/
libs/protobuf-c/Makefile
@@
-48,6
+48,7
@@
endef
CMAKE_HOST_OPTIONS += \
-DBUILD_SHARED_LIBS=ON \
+ -DCMAKE_CXX_STANDARD=11 \
-DCMAKE_SKIP_RPATH=OFF \
-DCMAKE_INSTALL_RPATH="${STAGING_DIR_HOSTPKG}/lib"