perl-file-next: add new package
authorTianling Shen <cnsztl@immortalwrt.org>
Tue, 20 Apr 2021 14:11:37 +0000 (22:11 +0800)
committerTianling Shen <cnsztl@immortalwrt.org>
Fri, 28 May 2021 14:38:29 +0000 (22:38 +0800)
This is required by ack.

Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
lang/perl-file-next/Makefile [new file with mode: 0644]

diff --git a/lang/perl-file-next/Makefile b/lang/perl-file-next/Makefile
new file mode 100644 (file)
index 0000000..62fe434
--- /dev/null
@@ -0,0 +1,44 @@
+# SPDX-License-Identifier: GPL-3.0-only
+#
+# Copyright (C) 2021 ImmortalWrt.org
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=perl-file-next
+PKG_VERSION:=1.18
+PKG_RELEASE:=$(AUTORELEASE)
+
+PKG_SOURCE_URL:=http://www.cpan.org/authors/id/P/PE/PETDANCE/
+PKG_SOURCE:=File-Next-$(PKG_VERSION).tar.gz
+PKG_HASH:=f900cb39505eb6e168a9ca51a10b73f1bbde1914b923a09ecd72d9c02e6ec2ef
+
+PKG_LICENSE:=Artistic-2.0
+PKG_MAINTAINER:=Tianling Shen <cnsztl@immortalwrt.org>
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/perl/File-Next-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+include ../perl/perlmod.mk
+
+define Package/perl-file-next
+  SUBMENU:=Perl
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=File finding module
+  URL:=http://search.cpan.org/dist/File-Next/
+  DEPENDS:=perl +perlbase-file
+endef
+
+define Build/Configure
+       $(call perlmod/Configure,,)
+endef
+
+define Build/Compile
+       $(call perlmod/Compile,,)
+endef
+
+define Package/perl-file-next/install
+       $(call perlmod/Install,$(1),File auto/File)
+endef
+
+$(eval $(call BuildPackage,perl-file-next))