kamailio-5.x: fix RPATH of kamailio modules
authorSebastian Kemper <sebastian_ml@gmx.net>
Sun, 11 Feb 2018 18:18:05 +0000 (19:18 +0100)
committerSebastian Kemper <sebastian_ml@gmx.net>
Sun, 11 Feb 2018 18:18:07 +0000 (19:18 +0100)
The kamailio build system provides an RPATH "///usr/lib/kamailio/" when
linking. OpenWrt's rstrip.sh inspects this RPATH and drops it. Now the
modules cannot find the needed libraries. Fix this by specifying a path
that rstrip.sh accepts.

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
net/kamailio-5.x/Makefile

index af94cd0261b03ae1bb4f2a3e95f9c6c3abb109e1..47cd103b9098026d49754c5b165e171deea64e63 100644 (file)
@@ -116,6 +116,9 @@ endef
 
 TARGET_CPPFLAGS+=$(if $(CONFIG_PACKAGE_kamailio5-mod-app-python),-I$(STAGING_DIR)/usr/include/python$(PYTHON_VERSION))
 
+# "lib_target" is specified in order for the modules to get a proper
+# RPATH, as otherwise they would not find the internal libraries.
+
 PKG_MAKE_ARGS:= \
        prefix=/ \
        cfg_dir=/etc/kamailio/ \
@@ -126,6 +129,7 @@ PKG_MAKE_ARGS:= \
        group_include="standard" \
        include_modules="$$(INCL_MODULES)" \
        cfg_target:=/etc/kamailio/ \
+       lib_target=/usr/lib/kamailio/ \
        CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
        LD_EXTRA_OPTS="$(TARGET_LDFLAGS)" \
        LOCALBASE="$(STAGING_DIR)/usr" \