build system cleanup/restructuring as described in http://lists.openwrt.org/pipermail...
authorFelix Fietkau <nbd@openwrt.org>
Tue, 7 Aug 2007 00:04:25 +0000 (00:04 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 7 Aug 2007 00:04:25 +0000 (00:04 +0000)
SVN-Revision: 8362

Makefile

index 24cf88eecd6f247d35450917f15eeaec50e5771f..f458693564915248e2001ceb1b1893f234347359 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -7,14 +7,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME := firmware-utils
-PKG_BUILD_DIR:=$(TOOL_BUILD_DIR)/firmware-utils
 
 include $(INCLUDE_DIR)/host-build.mk
 
-CFLAGS := -O2 -I $(STAGING_DIR)/include-host -include endian.h
-
 define cc
-       $(CC) $(CFLAGS) -o $(PKG_BUILD_DIR)/bin/$(1) src/$(1).c
+       $(CC) $(HOST_CFLAGS) -include endian.h -o $(PKG_BUILD_DIR)/bin/$(1) src/$(1).c
 endef
 
 define Build/Compile
@@ -33,7 +30,7 @@ define Build/Compile
 endef
 
 define Build/Install
-       $(CP) $(PKG_BUILD_DIR)/bin/* $(STAGING_DIR)/bin
+       $(CP) $(PKG_BUILD_DIR)/bin/* $(STAGING_DIR_HOST)/bin/
 endef
 
 $(eval $(call HostBuild))