trusted-firmware-a.mk: fix release download URL
authorChukun Pan <amadeus@jmu.edu.cn>
Fri, 20 Dec 2024 14:30:01 +0000 (22:30 +0800)
committerRobert Marko <robimarko@gmail.com>
Sat, 28 Dec 2024 10:20:20 +0000 (11:20 +0100)
The URL of trusted-firmware-a is no longer available for
downloading release:
https://git.trustedfirmware.org/TF-A/trusted-firmware-a.git/
curl: (22) The requested URL returned error: 401 Unauthorized

So we switch to the GitHub mirror repository to download.

Signed-off-by: Chukun Pan <amadeus@jmu.edu.cn>
Link: https://github.com/openwrt/openwrt/pull/17360
Signed-off-by: Robert Marko <robimarko@gmail.com>
include/trusted-firmware-a.mk
package/boot/arm-trusted-firmware-stm32/Makefile

index b44cec8d07486d4855955350ac6999fafcdd795b..c0d11d68c4beeff0dda33334c206d8ccee91f950 100644 (file)
@@ -3,7 +3,7 @@ PKG_CPE_ID ?= cpe:/a:arm:trusted_firmware-a
 
 ifndef PKG_SOURCE_PROTO
 PKG_SOURCE = trusted-firmware-a-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://git.trustedfirmware.org/TF-A/trusted-firmware-a.git/snapshot
+PKG_SOURCE_URL:=https://codeload.github.com/TrustedFirmware-A/trusted-firmware-a/tar.gz/v$(PKG_VERSION)?
 endif
 
 PKG_BUILD_DIR = $(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
index 7f486885d3ae93cffc1fa511c15036d7dc7bb951..403f53acc8ebfc0f5083336d1b7f1d8946618161 100644 (file)
@@ -10,10 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_VERSION:=2.12
 PKG_RELEASE:=1
 
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=https://github.com/ARM-software/arm-trusted-firmware.git
-PKG_SOURCE_VERSION:=v$(PKG_VERSION)
-PKG_MIRROR_HASH:=51b2022baa25df7fd8f2e6d2709c9351c14b17447cda64759a8a1d432f9d1c11
+PKG_HASH:=b4c047493cac1152203e1ba121ae57267e4899b7bf56eb365e22a933342d31c9
 PKG_MAINTAINER:=Thomas Richard <thomas.richard@bootlin.com>
 
 include $(INCLUDE_DIR)/kernel.mk