libowfat: fix build
authorFlorian Fainelli <florian@openwrt.org>
Sat, 8 Mar 2014 00:56:50 +0000 (00:56 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 8 Mar 2014 00:56:50 +0000 (00:56 +0000)
libowfat build was failing due to the CFLAGS being overriden in the Makefile
which will make all the preliminary tests to fail.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 39805

libs/libowfat/Makefile

index 23a8869202e642624cd8bf5e9ba42d0840642812..2741f4930c1d791990b61b9790e0b9637cc4fe26 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -11,7 +11,7 @@ LOWFAT_VERSION=0.28
 
 PKG_NAME:=libowfat
 PKG_VERSION:=$(LOWFAT_VERSION)
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://dl.fefe.de
@@ -34,10 +34,9 @@ endef
 
 TARGET_CFLAGS += $(FPIC)
 LOWFAT_MAKEOPTS = $(TARGET_CONFIGURE_OPTS) \
-       COPTS="$(TARGET_CFLAGS)" \
+       CFLAGS="$(TARGET_CFLAGS) -I$(PKG_BUILD_DIR) -I$(STAGING_DIR)/usr/include" \
        DEBUG="$(DEBUG)" \
        VERSION="$(LOWFAT_VERSION)" \
-       CPPFLAGS="-I$(PKG_BUILD_DIR) -I$(STAGING_DIR)/usr/include" \
        OS="Linux"
 
 # work around a nasty gcc bug