firmware: Move Trusted Foundations support
authorThierry Reding <treding@nvidia.com>
Wed, 10 Apr 2019 08:47:28 +0000 (10:47 +0200)
committerThierry Reding <treding@nvidia.com>
Wed, 17 Apr 2019 14:43:03 +0000 (16:43 +0200)
Move the Trusted Foundations support out of arch/arm/firmware and into
drivers/firmware where most other firmware support implementations are
located.

Signed-off-by: Thierry Reding <treding@nvidia.com>
15 files changed:
arch/arm/Kconfig
arch/arm/Makefile
arch/arm/firmware/Kconfig [deleted file]
arch/arm/firmware/Makefile [deleted file]
arch/arm/firmware/trusted_foundations.c [deleted file]
arch/arm/include/asm/trusted_foundations.h [deleted file]
arch/arm/mach-tegra/Kconfig
arch/arm/mach-tegra/cpuidle-tegra114.c
arch/arm/mach-tegra/pm.c
arch/arm/mach-tegra/reset.c
arch/arm/mach-tegra/tegra.c
drivers/firmware/Kconfig
drivers/firmware/Makefile
drivers/firmware/trusted_foundations.c [new file with mode: 0644]
include/linux/firmware/trusted_foundations.h [new file with mode: 0644]

index 054ead960f983a99a9f241ce1427fe0e1cd6cb8a..f006b3c69247385b6b12887061578347cb075757 100644 (file)
@@ -899,8 +899,6 @@ config PLAT_PXA
 config PLAT_VERSATILE
        bool
 
-source "arch/arm/firmware/Kconfig"
-
 source "arch/arm/mm/Kconfig"
 
 config IWMMXT
index 807a7d06c2a0825bed8f8ea8c1d9d8c7eb5f8be6..05ecc004de867a5d24ea251cd84649476c21efdc 100644 (file)
@@ -290,7 +290,6 @@ core-y                              += arch/arm/kernel/ arch/arm/mm/ arch/arm/common/
 core-y                         += arch/arm/probes/
 core-y                         += arch/arm/net/
 core-y                         += arch/arm/crypto/
-core-y                         += arch/arm/firmware/
 core-y                         += $(machdirs) $(platdirs)
 
 drivers-$(CONFIG_OPROFILE)      += arch/arm/oprofile/
diff --git a/arch/arm/firmware/Kconfig b/arch/arm/firmware/Kconfig
deleted file mode 100644 (file)
index ad396af..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-config ARCH_SUPPORTS_FIRMWARE
-       bool
-
-config ARCH_SUPPORTS_TRUSTED_FOUNDATIONS
-       bool
-       select ARCH_SUPPORTS_FIRMWARE
-
-menu "Firmware options"
-       depends on ARCH_SUPPORTS_FIRMWARE
-
-config TRUSTED_FOUNDATIONS
-       bool "Trusted Foundations secure monitor support"
-       depends on ARCH_SUPPORTS_TRUSTED_FOUNDATIONS
-       default y
-       help
-         Some devices (including most Tegra-based consumer devices on the
-         market) are booted with the Trusted Foundations secure monitor
-         active, requiring some core operations to be performed by the secure
-         monitor instead of the kernel.
-
-         This option allows the kernel to invoke the secure monitor whenever
-         required on devices using Trusted Foundations. See
-         arch/arm/include/asm/trusted_foundations.h or the
-         tlm,trusted-foundations device tree binding documentation for details
-         on how to use it.
-
-         Say n if you don't know what this is about.
-
-endmenu
diff --git a/arch/arm/firmware/Makefile b/arch/arm/firmware/Makefile
deleted file mode 100644 (file)
index 6e41336..0000000
+++ /dev/null
@@ -1,4 +0,0 @@
-obj-$(CONFIG_TRUSTED_FOUNDATIONS)      += trusted_foundations.o
-
-# tf_generic_smc() fails to build with -fsanitize-coverage=trace-pc
-KCOV_INSTRUMENT                := n
diff --git a/arch/arm/firmware/trusted_foundations.c b/arch/arm/firmware/trusted_foundations.c
deleted file mode 100644 (file)
index bb2ee73..0000000
+++ /dev/null
@@ -1,174 +0,0 @@
-/*
- * Trusted Foundations support for ARM CPUs
- *
- * Copyright (c) 2013, NVIDIA Corporation.
- *
- * This program is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation; either version 2 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful, but WITHOUT
- * ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
- * FITNESS FOR A PARTICULAR PURPOSE.  See the GNU General Public License for
- * more details.
- */
-
-#include <linux/kernel.h>
-#include <linux/init.h>
-#include <linux/of.h>
-#include <asm/firmware.h>
-#include <asm/hardware/cache-l2x0.h>
-#include <asm/outercache.h>
-#include <asm/trusted_foundations.h>
-
-#define TF_CACHE_MAINT         0xfffff100
-
-#define TF_CACHE_ENABLE                1
-#define TF_CACHE_DISABLE       2
-
-#define TF_SET_CPU_BOOT_ADDR_SMC 0xfffff200
-
-#define TF_CPU_PM              0xfffffffc
-#define TF_CPU_PM_S3           0xffffffe3
-#define TF_CPU_PM_S2           0xffffffe6
-#define TF_CPU_PM_S2_NO_MC_CLK 0xffffffe5
-#define TF_CPU_PM_S1           0xffffffe4
-#define TF_CPU_PM_S1_NOFLUSH_L2        0xffffffe7
-
-static unsigned long cpu_boot_addr;
-
-static void tf_generic_smc(u32 type, u32 arg1, u32 arg2)
-{
-       register u32 r0 asm("r0") = type;
-       register u32 r1 asm("r1") = arg1;
-       register u32 r2 asm("r2") = arg2;
-
-       asm volatile(
-               ".arch_extension        sec\n\t"
-               "stmfd  sp!, {r4 - r11}\n\t"
-               __asmeq("%0", "r0")
-               __asmeq("%1", "r1")
-               __asmeq("%2", "r2")
-               "mov    r3, #0\n\t"
-               "mov    r4, #0\n\t"
-               "smc    #0\n\t"
-               "ldmfd  sp!, {r4 - r11}\n\t"
-               :
-               : "r" (r0), "r" (r1), "r" (r2)
-               : "memory", "r3", "r12", "lr");
-}
-
-static int tf_set_cpu_boot_addr(int cpu, unsigned long boot_addr)
-{
-       cpu_boot_addr = boot_addr;
-       tf_generic_smc(TF_SET_CPU_BOOT_ADDR_SMC, cpu_boot_addr, 0);
-
-       return 0;
-}
-
-static int tf_prepare_idle(unsigned long mode)
-{
-       switch (mode) {
-       case TF_PM_MODE_LP0:
-               tf_generic_smc(TF_CPU_PM, TF_CPU_PM_S3, cpu_boot_addr);
-               break;
-
-       case TF_PM_MODE_LP1:
-               tf_generic_smc(TF_CPU_PM, TF_CPU_PM_S2, cpu_boot_addr);
-               break;
-
-       case TF_PM_MODE_LP1_NO_MC_CLK:
-               tf_generic_smc(TF_CPU_PM, TF_CPU_PM_S2_NO_MC_CLK,
-                              cpu_boot_addr);
-               break;
-
-       case TF_PM_MODE_LP2:
-               tf_generic_smc(TF_CPU_PM, TF_CPU_PM_S1, cpu_boot_addr);
-               break;
-
-       case TF_PM_MODE_LP2_NOFLUSH_L2:
-               tf_generic_smc(TF_CPU_PM, TF_CPU_PM_S1_NOFLUSH_L2,
-                              cpu_boot_addr);
-               break;
-
-       default:
-               return -EINVAL;
-       }
-
-       return 0;
-}
-
-#ifdef CONFIG_CACHE_L2X0
-static void tf_cache_write_sec(unsigned long val, unsigned int reg)
-{
-       u32 l2x0_way_mask = 0xff;
-
-       switch (reg) {
-       case L2X0_CTRL:
-               if (l2x0_saved_regs.aux_ctrl & L310_AUX_CTRL_ASSOCIATIVITY_16)
-                       l2x0_way_mask = 0xffff;
-
-               if (val == L2X0_CTRL_EN)
-                       tf_generic_smc(TF_CACHE_MAINT, TF_CACHE_ENABLE,
-                                      l2x0_saved_regs.aux_ctrl);
-               else
-                       tf_generic_smc(TF_CACHE_MAINT, TF_CACHE_DISABLE,
-                                      l2x0_way_mask);
-               break;
-
-       default:
-               break;
-       }
-}
-
-static int tf_init_cache(void)
-{
-       outer_cache.write_sec = tf_cache_write_sec;
-
-       return 0;
-}
-#endif /* CONFIG_CACHE_L2X0 */
-
-static const struct firmware_ops trusted_foundations_ops = {
-       .set_cpu_boot_addr = tf_set_cpu_boot_addr,
-       .prepare_idle = tf_prepare_idle,
-#ifdef CONFIG_CACHE_L2X0
-       .l2x0_init = tf_init_cache,
-#endif
-};
-
-void register_trusted_foundations(struct trusted_foundations_platform_data *pd)
-{
-       /*
-        * we are not using version information for now since currently
-        * supported SMCs are compatible with all TF releases
-        */
-       register_firmware_ops(&trusted_foundations_ops);
-}
-
-void of_register_trusted_foundations(void)
-{
-       struct device_node *node;
-       struct trusted_foundations_platform_data pdata;
-       int err;
-
-       node = of_find_compatible_node(NULL, NULL, "tlm,trusted-foundations");
-       if (!node)
-               return;
-
-       err = of_property_read_u32(node, "tlm,version-major",
-                                  &pdata.version_major);
-       if (err != 0)
-               panic("Trusted Foundation: missing version-major property\n");
-       err = of_property_read_u32(node, "tlm,version-minor",
-                                  &pdata.version_minor);
-       if (err != 0)
-               panic("Trusted Foundation: missing version-minor property\n");
-       register_trusted_foundations(&pdata);
-}
-
-bool trusted_foundations_registered(void)
-{
-       return firmware_ops == &trusted_foundations_ops;
-}
diff --git a/arch/arm/include/asm/trusted_foundations.h b/arch/arm/include/asm/trusted_foundations.h
deleted file mode 100644 (file)
index 54513c5..0000000
+++ /dev/null
@@ -1,96 +0,0 @@
-/*
- * Copyright (c) 2013, NVIDIA Corporation.
- *
- * This program is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation; either version 2 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful, but WITHOUT
- * ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
- * FITNESS FOR A PARTICULAR PURPOSE.  See the GNU General Public License for
- * more details.
- */
-
-/*
- * Support for the Trusted Foundations secure monitor.
- *
- * Trusted Foundation comes active on some ARM consumer devices (most
- * Tegra-based devices sold on the market are concerned). Such devices can only
- * perform some basic operations, like setting the CPU reset vector, through
- * SMC calls to the secure monitor. The calls are completely specific to
- * Trusted Foundations, and do *not* follow the SMC calling convention or the
- * PSCI standard.
- */
-
-#ifndef __ASM_ARM_TRUSTED_FOUNDATIONS_H
-#define __ASM_ARM_TRUSTED_FOUNDATIONS_H
-
-#include <linux/printk.h>
-#include <linux/bug.h>
-#include <linux/of.h>
-#include <linux/cpu.h>
-#include <linux/smp.h>
-#include <linux/types.h>
-
-#include <asm/hardware/cache-l2x0.h>
-#include <asm/outercache.h>
-
-#define TF_PM_MODE_LP0                 0
-#define TF_PM_MODE_LP1                 1
-#define TF_PM_MODE_LP1_NO_MC_CLK       2
-#define TF_PM_MODE_LP2                 3
-#define TF_PM_MODE_LP2_NOFLUSH_L2      4
-
-struct trusted_foundations_platform_data {
-       unsigned int version_major;
-       unsigned int version_minor;
-};
-
-#if IS_ENABLED(CONFIG_TRUSTED_FOUNDATIONS)
-
-void register_trusted_foundations(struct trusted_foundations_platform_data *pd);
-void of_register_trusted_foundations(void);
-bool trusted_foundations_registered(void);
-
-#else /* CONFIG_TRUSTED_FOUNDATIONS */
-static inline void tf_dummy_write_sec(unsigned long val, unsigned int reg)
-{
-}
-
-static inline void register_trusted_foundations(
-                                  struct trusted_foundations_platform_data *pd)
-{
-       /*
-        * If the system requires TF and we cannot provide it, continue booting
-        * but disable features that cannot be provided.
-        */
-       pr_err("No support for Trusted Foundations, continuing in degraded mode.\n");
-       pr_err("Secondary processors as well as CPU PM will be disabled.\n");
-#if IS_ENABLED(CONFIG_CACHE_L2X0)
-       pr_err("L2X0 cache will be kept disabled.\n");
-       outer_cache.write_sec = tf_dummy_write_sec;
-#endif
-#if IS_ENABLED(CONFIG_SMP)
-       setup_max_cpus = 0;
-#endif
-       cpu_idle_poll_ctrl(true);
-}
-
-static inline void of_register_trusted_foundations(void)
-{
-       /*
-        * If we find the target should enable TF but does not support it,
-        * fail as the system won't be able to do much anyway
-        */
-       if (of_find_compatible_node(NULL, NULL, "tlm,trusted-foundations"))
-               register_trusted_foundations(NULL);
-}
-
-static inline bool trusted_foundations_registered(void)
-{
-       return false;
-}
-#endif /* CONFIG_TRUSTED_FOUNDATIONS */
-
-#endif
index 7b3fd0995a1647fdb81a8e0daaf6642020ba86bf..63e89e75639bd0e3fffe7fb6e9852cb93f153bc4 100644 (file)
@@ -3,7 +3,6 @@ menuconfig ARCH_TEGRA
        bool "NVIDIA Tegra"
        depends on ARCH_MULTI_V7
        select ARCH_HAS_RESET_CONTROLLER
-       select ARCH_SUPPORTS_TRUSTED_FOUNDATIONS
        select ARM_AMBA
        select ARM_GIC
        select CLKSRC_MMIO
index 3b9af4766cdf101d50480b293b70f44192514eb6..43c695d83f03467eb89e316d29d213385a80b85d 100644 (file)
 #include <linux/kernel.h>
 #include <linux/module.h>
 
+#include <linux/firmware/trusted_foundations.h>
+
 #include <asm/cpuidle.h>
 #include <asm/smp_plat.h>
 #include <asm/suspend.h>
-#include <asm/trusted_foundations.h>
 #include <asm/psci.h>
 
 #include "cpuidle.h"
index abf5f88778f4ed120d0ea0a1c6c87dff6e95f7d0..1b0ade06f204e667847fa4e86452373b9fa7c53c 100644 (file)
@@ -27,6 +27,8 @@
 #include <linux/spinlock.h>
 #include <linux/suspend.h>
 
+#include <linux/firmware/trusted_foundations.h>
+
 #include <soc/tegra/flowctrl.h>
 #include <soc/tegra/fuse.h>
 #include <soc/tegra/pm.h>
@@ -39,7 +41,6 @@
 #include <asm/smp_plat.h>
 #include <asm/suspend.h>
 #include <asm/tlbflush.h>
-#include <asm/trusted_foundations.h>
 
 #include "iomap.h"
 #include "pm.h"
index b02ae7699842c382fdfbe9af1a2c81f85b19325d..35dc5d419b6f2351b93c7af6b44097b4202d7bf1 100644 (file)
 #include <linux/init.h>
 #include <linux/io.h>
 
+#include <linux/firmware/trusted_foundations.h>
+
 #include <soc/tegra/fuse.h>
 
 #include <asm/cacheflush.h>
 #include <asm/firmware.h>
 #include <asm/hardware/cache-l2x0.h>
-#include <asm/trusted_foundations.h>
 
 #include "iomap.h"
 #include "irammap.h"
index 1e89cfefbf68fe3dcabddca50a22fb518f514279..3e88f67dd5217965d3da344b6f9d51d59b8a50cf 100644 (file)
@@ -35,6 +35,8 @@
 #include <linux/sys_soc.h>
 #include <linux/usb/tegra_usb_phy.h>
 
+#include <linux/firmware/trusted_foundations.h>
+
 #include <soc/tegra/fuse.h>
 #include <soc/tegra/pmc.h>
 
@@ -44,7 +46,6 @@
 #include <asm/mach/time.h>
 #include <asm/mach-types.h>
 #include <asm/setup.h>
-#include <asm/trusted_foundations.h>
 
 #include "board.h"
 #include "common.h"
index cac16c4b0df3eb6232b75cb7237091a5fda8f95e..f0646ac7586826a2fc16ad216b8640419f889cee 100644 (file)
@@ -267,6 +267,22 @@ config TI_SCI_PROTOCOL
          This protocol library is used by client drivers to use the features
          provided by the system controller.
 
+config TRUSTED_FOUNDATIONS
+       bool "Trusted Foundations secure monitor support"
+       depends on ARM
+       help
+         Some devices (including most early Tegra-based consumer devices on
+         the market) are booted with the Trusted Foundations secure monitor
+         active, requiring some core operations to be performed by the secure
+         monitor instead of the kernel.
+
+         This option allows the kernel to invoke the secure monitor whenever
+         required on devices using Trusted Foundations. See the functions and
+         comments in linux/firmware/trusted_foundations.h or the device tree
+         bindings for "tlm,trusted-foundations" for details on how to use it.
+
+         Choose N if you don't know what this is about.
+
 config HAVE_ARM_SMCCC
        bool
 
index 80feb635120fc72283da432b08ba1f6eed8aa9dd..745f4907e69b8c0784ae5554a82dd7bc17376b7f 100644 (file)
@@ -23,6 +23,7 @@ obj-$(CONFIG_QCOM_SCM_64)     += qcom_scm-64.o
 obj-$(CONFIG_QCOM_SCM_32)      += qcom_scm-32.o
 CFLAGS_qcom_scm-32.o :=$(call as-instr,.arch armv7-a\n.arch_extension sec,-DREQUIRES_SEC=1) -march=armv7-a
 obj-$(CONFIG_TI_SCI_PROTOCOL)  += ti_sci.o
+obj-$(CONFIG_TRUSTED_FOUNDATIONS) += trusted_foundations.o
 
 obj-$(CONFIG_ARM_SCMI_PROTOCOL)        += arm_scmi/
 obj-y                          += broadcom/
diff --git a/drivers/firmware/trusted_foundations.c b/drivers/firmware/trusted_foundations.c
new file mode 100644 (file)
index 0000000..fd49993
--- /dev/null
@@ -0,0 +1,176 @@
+/*
+ * Trusted Foundations support for ARM CPUs
+ *
+ * Copyright (c) 2013, NVIDIA Corporation.
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful, but WITHOUT
+ * ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+ * FITNESS FOR A PARTICULAR PURPOSE.  See the GNU General Public License for
+ * more details.
+ */
+
+#include <linux/kernel.h>
+#include <linux/init.h>
+#include <linux/of.h>
+
+#include <linux/firmware/trusted_foundations.h>
+
+#include <asm/firmware.h>
+#include <asm/hardware/cache-l2x0.h>
+#include <asm/outercache.h>
+
+#define TF_CACHE_MAINT         0xfffff100
+
+#define TF_CACHE_ENABLE                1
+#define TF_CACHE_DISABLE       2
+
+#define TF_SET_CPU_BOOT_ADDR_SMC 0xfffff200
+
+#define TF_CPU_PM              0xfffffffc
+#define TF_CPU_PM_S3           0xffffffe3
+#define TF_CPU_PM_S2           0xffffffe6
+#define TF_CPU_PM_S2_NO_MC_CLK 0xffffffe5
+#define TF_CPU_PM_S1           0xffffffe4
+#define TF_CPU_PM_S1_NOFLUSH_L2        0xffffffe7
+
+static unsigned long cpu_boot_addr;
+
+static void tf_generic_smc(u32 type, u32 arg1, u32 arg2)
+{
+       register u32 r0 asm("r0") = type;
+       register u32 r1 asm("r1") = arg1;
+       register u32 r2 asm("r2") = arg2;
+
+       asm volatile(
+               ".arch_extension        sec\n\t"
+               "stmfd  sp!, {r4 - r11}\n\t"
+               __asmeq("%0", "r0")
+               __asmeq("%1", "r1")
+               __asmeq("%2", "r2")
+               "mov    r3, #0\n\t"
+               "mov    r4, #0\n\t"
+               "smc    #0\n\t"
+               "ldmfd  sp!, {r4 - r11}\n\t"
+               :
+               : "r" (r0), "r" (r1), "r" (r2)
+               : "memory", "r3", "r12", "lr");
+}
+
+static int tf_set_cpu_boot_addr(int cpu, unsigned long boot_addr)
+{
+       cpu_boot_addr = boot_addr;
+       tf_generic_smc(TF_SET_CPU_BOOT_ADDR_SMC, cpu_boot_addr, 0);
+
+       return 0;
+}
+
+static int tf_prepare_idle(unsigned long mode)
+{
+       switch (mode) {
+       case TF_PM_MODE_LP0:
+               tf_generic_smc(TF_CPU_PM, TF_CPU_PM_S3, cpu_boot_addr);
+               break;
+
+       case TF_PM_MODE_LP1:
+               tf_generic_smc(TF_CPU_PM, TF_CPU_PM_S2, cpu_boot_addr);
+               break;
+
+       case TF_PM_MODE_LP1_NO_MC_CLK:
+               tf_generic_smc(TF_CPU_PM, TF_CPU_PM_S2_NO_MC_CLK,
+                              cpu_boot_addr);
+               break;
+
+       case TF_PM_MODE_LP2:
+               tf_generic_smc(TF_CPU_PM, TF_CPU_PM_S1, cpu_boot_addr);
+               break;
+
+       case TF_PM_MODE_LP2_NOFLUSH_L2:
+               tf_generic_smc(TF_CPU_PM, TF_CPU_PM_S1_NOFLUSH_L2,
+                              cpu_boot_addr);
+               break;
+
+       default:
+               return -EINVAL;
+       }
+
+       return 0;
+}
+
+#ifdef CONFIG_CACHE_L2X0
+static void tf_cache_write_sec(unsigned long val, unsigned int reg)
+{
+       u32 l2x0_way_mask = 0xff;
+
+       switch (reg) {
+       case L2X0_CTRL:
+               if (l2x0_saved_regs.aux_ctrl & L310_AUX_CTRL_ASSOCIATIVITY_16)
+                       l2x0_way_mask = 0xffff;
+
+               if (val == L2X0_CTRL_EN)
+                       tf_generic_smc(TF_CACHE_MAINT, TF_CACHE_ENABLE,
+                                      l2x0_saved_regs.aux_ctrl);
+               else
+                       tf_generic_smc(TF_CACHE_MAINT, TF_CACHE_DISABLE,
+                                      l2x0_way_mask);
+               break;
+
+       default:
+               break;
+       }
+}
+
+static int tf_init_cache(void)
+{
+       outer_cache.write_sec = tf_cache_write_sec;
+
+       return 0;
+}
+#endif /* CONFIG_CACHE_L2X0 */
+
+static const struct firmware_ops trusted_foundations_ops = {
+       .set_cpu_boot_addr = tf_set_cpu_boot_addr,
+       .prepare_idle = tf_prepare_idle,
+#ifdef CONFIG_CACHE_L2X0
+       .l2x0_init = tf_init_cache,
+#endif
+};
+
+void register_trusted_foundations(struct trusted_foundations_platform_data *pd)
+{
+       /*
+        * we are not using version information for now since currently
+        * supported SMCs are compatible with all TF releases
+        */
+       register_firmware_ops(&trusted_foundations_ops);
+}
+
+void of_register_trusted_foundations(void)
+{
+       struct device_node *node;
+       struct trusted_foundations_platform_data pdata;
+       int err;
+
+       node = of_find_compatible_node(NULL, NULL, "tlm,trusted-foundations");
+       if (!node)
+               return;
+
+       err = of_property_read_u32(node, "tlm,version-major",
+                                  &pdata.version_major);
+       if (err != 0)
+               panic("Trusted Foundation: missing version-major property\n");
+       err = of_property_read_u32(node, "tlm,version-minor",
+                                  &pdata.version_minor);
+       if (err != 0)
+               panic("Trusted Foundation: missing version-minor property\n");
+       register_trusted_foundations(&pdata);
+}
+
+bool trusted_foundations_registered(void)
+{
+       return firmware_ops == &trusted_foundations_ops;
+}
diff --git a/include/linux/firmware/trusted_foundations.h b/include/linux/firmware/trusted_foundations.h
new file mode 100644 (file)
index 0000000..4064e7c
--- /dev/null
@@ -0,0 +1,96 @@
+/*
+ * Copyright (c) 2013, NVIDIA Corporation.
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful, but WITHOUT
+ * ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+ * FITNESS FOR A PARTICULAR PURPOSE.  See the GNU General Public License for
+ * more details.
+ */
+
+/*
+ * Support for the Trusted Foundations secure monitor.
+ *
+ * Trusted Foundation comes active on some ARM consumer devices (most
+ * Tegra-based devices sold on the market are concerned). Such devices can only
+ * perform some basic operations, like setting the CPU reset vector, through
+ * SMC calls to the secure monitor. The calls are completely specific to
+ * Trusted Foundations, and do *not* follow the SMC calling convention or the
+ * PSCI standard.
+ */
+
+#ifndef __FIRMWARE_TRUSTED_FOUNDATIONS_H
+#define __FIRMWARE_TRUSTED_FOUNDATIONS_H
+
+#include <linux/printk.h>
+#include <linux/bug.h>
+#include <linux/of.h>
+#include <linux/cpu.h>
+#include <linux/smp.h>
+#include <linux/types.h>
+
+#include <asm/hardware/cache-l2x0.h>
+#include <asm/outercache.h>
+
+#define TF_PM_MODE_LP0                 0
+#define TF_PM_MODE_LP1                 1
+#define TF_PM_MODE_LP1_NO_MC_CLK       2
+#define TF_PM_MODE_LP2                 3
+#define TF_PM_MODE_LP2_NOFLUSH_L2      4
+
+struct trusted_foundations_platform_data {
+       unsigned int version_major;
+       unsigned int version_minor;
+};
+
+#if IS_ENABLED(CONFIG_TRUSTED_FOUNDATIONS)
+
+void register_trusted_foundations(struct trusted_foundations_platform_data *pd);
+void of_register_trusted_foundations(void);
+bool trusted_foundations_registered(void);
+
+#else /* CONFIG_TRUSTED_FOUNDATIONS */
+static inline void tf_dummy_write_sec(unsigned long val, unsigned int reg)
+{
+}
+
+static inline void register_trusted_foundations(
+                                  struct trusted_foundations_platform_data *pd)
+{
+       /*
+        * If the system requires TF and we cannot provide it, continue booting
+        * but disable features that cannot be provided.
+        */
+       pr_err("No support for Trusted Foundations, continuing in degraded mode.\n");
+       pr_err("Secondary processors as well as CPU PM will be disabled.\n");
+#if IS_ENABLED(CONFIG_CACHE_L2X0)
+       pr_err("L2X0 cache will be kept disabled.\n");
+       outer_cache.write_sec = tf_dummy_write_sec;
+#endif
+#if IS_ENABLED(CONFIG_SMP)
+       setup_max_cpus = 0;
+#endif
+       cpu_idle_poll_ctrl(true);
+}
+
+static inline void of_register_trusted_foundations(void)
+{
+       /*
+        * If we find the target should enable TF but does not support it,
+        * fail as the system won't be able to do much anyway
+        */
+       if (of_find_compatible_node(NULL, NULL, "tlm,trusted-foundations"))
+               register_trusted_foundations(NULL);
+}
+
+static inline bool trusted_foundations_registered(void)
+{
+       return false;
+}
+#endif /* CONFIG_TRUSTED_FOUNDATIONS */
+
+#endif