xfsprogs: fix compilation under glibc
authorRosen Penev <rosenp@gmail.com>
Thu, 31 Dec 2020 00:51:39 +0000 (16:51 -0800)
committerRosen Penev <rosenp@gmail.com>
Thu, 31 Dec 2020 00:52:59 +0000 (16:52 -0800)
Missing link to librt.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
utils/xfsprogs/Makefile

index b885b15459b9d9be531793f1b8a03cb32eac47e0..77cb580667e52335c8a9ad76055f930fe81f036d 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=xfsprogs
 PKG_VERSION:=5.9.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/utils/fs/xfs/xfsprogs
@@ -68,6 +68,7 @@ CONFIGURE_ARGS += \
        --disable-libicu
 
 TARGET_CFLAGS += -DHAVE_MAP_SYNC
+TARGET_LDFLAGS += $(if $(CONFIG_USE_GLIBC),-lrt)
 
 define Package/xfs-admin/install
        $(INSTALL_DIR) $(1)/sbin