projects
/
openwrt
/
svn-archive
/
packages.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
3835f45
)
alsa: add audio group in postinstall (#8755)
author
Jo-Philipp Wich
<jow@openwrt.org>
Fri, 11 Mar 2011 21:03:00 +0000
(21:03 +0000)
committer
Jo-Philipp Wich
<jow@openwrt.org>
Fri, 11 Mar 2011 21:03:00 +0000
(21:03 +0000)
SVN-Revision: 26042
sound/alsa/Makefile
patch
|
blob
|
history
diff --git
a/sound/alsa/Makefile
b/sound/alsa/Makefile
index 23ca767821d00fe6f8737b976e8430cbadda47ab..74ed086ec622bda5ecd9c5723b87aa0065e49a49 100644
(file)
--- a/
sound/alsa/Makefile
+++ b/
sound/alsa/Makefile
@@
-26,6
+26,11
@@
define KernelPackage/alsa
AUTOLOAD=$(call AutoLoad,70,$(shell cat ./files/alsa.modules))
endef
+define KernelPackage/alsa/postinst
+ grep -qs "^audio:" "$$IPKG_INSTROOT/etc/group" || echo "audio:x:29:" >> "$$IPKG_INSTROOT/etc/group"
+ exit 0
+endef
+
ifeq ($(KERNEL),2.4)
ifeq ($(LINUX_KARCH),i386)
KERNEL_C_OPTS:= -Os -mpreferred-stack-boundary=2 -march=i486 -fno-unit-at-a-time