prometheus-node-exporter-lua: Add "node_textfile_mtime_seconds" metric
authorRob Hoelz <rob@hoelz.ro>
Fri, 2 Dec 2022 15:25:17 +0000 (09:25 -0600)
committerEtienne Champetier <champetier.etienne@gmail.com>
Sun, 16 Jun 2024 02:41:33 +0000 (04:41 +0200)
…for textfile collector, to make it more consistent with the upstream
Prometheus node-exporter

Signed-off-by: Rob Hoelz <rob@hoelz.ro>
[bump version]
Signed-off-by: Etienne Champetier <champetier.etienne@gmail.com>
utils/prometheus-node-exporter-lua/Makefile
utils/prometheus-node-exporter-lua/files/usr/lib/lua/prometheus-collectors/textfile.lua

index 74d4d09cd9a9f27f24d64f168fe878bb30d36421..519543758333be2c34b26735cb30cdcdbb15995e 100644 (file)
@@ -4,7 +4,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=prometheus-node-exporter-lua
-PKG_VERSION:=2024.06.15
+PKG_VERSION:=2024.06.16
 PKG_RELEASE:=1
 
 PKG_MAINTAINER:=Etienne CHAMPETIER <champetier.etienne@gmail.com>
index 118177f49092a3e20d22b8a49cd146e632ee0fe0..4df7e91a2539f051053b3c645e0690d4ee1da64d 100644 (file)
@@ -3,8 +3,14 @@
 local fs = require "nixio.fs"
 
 local function scrape()
+  local mtime_metric = metric("node_textfile_mtime_seconds", "gauge")
+
   for metrics in fs.glob("/var/prometheus/*.prom") do
     output(get_contents(metrics), '\n')
+    local stat = fs.stat(metrics)
+    if stat then
+      mtime_metric({ file = metrics }, stat.mtime)
+    end
   end
 end