sbc: Switch to @KERNEL alias, use LTO optimization
authorDaniel Engberg <daniel.engberg.lists@pyret.net>
Tue, 1 May 2018 10:02:43 +0000 (12:02 +0200)
committerDaniel Engberg <daniel.engberg.lists@pyret.net>
Fri, 4 May 2018 05:50:18 +0000 (07:50 +0200)
Switch to the @KERNEL alias
Use LTO optimization, reduces file size by ~20% (~10Kbyte)

With:
39K sbc_1.3-1_arm_cortex-a9_neon.ipk

Without:
51K sbc_1.3-1_arm_cortex-a9_neon.ipk

Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
libs/sbc/Makefile

index b493e8d3f7d34ca84ba59390276f3e002858c8fe..684fcc5ea1be92491722ba70ba323a2dc01b65ae 100644 (file)
@@ -9,10 +9,10 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sbc
 PKG_VERSION:=1.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_SOURCE_URL:=https://www.kernel.org/pub/linux/bluetooth/
+PKG_SOURCE_URL:=@KERNEL/linux/bluetooth/
 PKG_HASH:=e61022cf576f14190241e7071753fdacdce5d1dea89ffd704110fc50be689309
 
 PKG_LICENSE:=LGPL-2.1+
@@ -37,6 +37,9 @@ define Package/sbc/description
   Needed for A2DP support.
 endef
 
+TARGET_CFLAGS += -flto
+TARGET_LDFLAGS += -flto
+
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/sbc
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/sbc/sbc.h $(1)/usr/include/sbc/