ariang: use new configuration of Nginx
authorPeter Stadler <peter.stadler@student.uibk.ac.at>
Tue, 4 Feb 2020 12:14:15 +0000 (13:14 +0100)
committerPeter Stadler <peter.stadler@student.uibk.ac.at>
Tue, 4 Feb 2020 13:51:09 +0000 (14:51 +0100)
Remove the superfluous parts of the uci-defaults file.

Signed-off-by: Peter Stadler <peter.stadler@student.uibk.ac.at>
net/ariang/Makefile
net/ariang/files/80_ariang-nginx-support

index 48ff438cc9534c9960c8e4d2040770dfcfe3b447..7f6d27908666f58ad6bb81c20d286f5319afdf93 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ariang
 PKG_VERSION:=1.1.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_URL:=https://codeload.github.com/mayswind/AriaNg-DailyBuild/tar.gz/$(PKG_VERSION)?
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
index f3eea690f445a56b4191909bfb1cf1f191ca6837..0a89ccd1b2378f47c4bc606c81b760e7ce370754 100644 (file)
@@ -1,17 +1,5 @@
 #!/bin/sh
 
-
-if [ -f "/etc/nginx/nginx.conf" ] && [ -f "/etc/nginx/conf.d/ariang.locations" ];
-then
-       if [ "$( grep 'server_name  localhost;' < /etc/nginx/nginx.conf)" ] && 
-       [ ! "$( grep 'include conf.d/ariang.locations;' < /etc/nginx/nginx.conf)" ]; then
-               sed -i '/server_name  localhost;/\
-                       a\\tinclude conf.d/ariang.locations;' /etc/nginx/nginx.conf
-               if [ -f /var/run/nginx.pid ]; then
-                       /etc/init.d/nginx restart
-               fi
-       fi
-fi
+[ -x /etc/init.d/nginx ] && /etc/init.d/nginx running && /etc/init.d/nginx reload
 
 exit 0
-