django-simple-captcha: update packaging format + add python3 variant
authorAlexandru Ardelean <ardeleanalex@gmail.com>
Wed, 3 Jul 2019 08:47:45 +0000 (11:47 +0300)
committerAlexandru Ardelean <ardeleanalex@gmail.com>
Thu, 11 Jul 2019 12:16:34 +0000 (15:16 +0300)
This change also updates the maintainer email to cotequeiroz@gmail.com, as
requested on a different change.

Also, changing here is the download URL to github's codeload, since that
one offers .tar.gz archives.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
lang/python/django-simple-captcha/Makefile
net/seafile-seahub/Makefile

index 96da70712ab7b5a1edb4ba00b793e040a63c6408..81d94d9eef4e788cb0b9541b10698b26e7f457f6 100644 (file)
@@ -9,34 +9,69 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=django-simple-captcha
 PKG_VERSION:=0.5.11
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
-PKG_MAINTAINER:=Eneas U de Queiroz <cote2004-github@yahoo.com>
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/mbi/django-simple-captcha/tar.gz/v$(PKG_VERSION)?
+PKG_HASH:=7ca26a4f48e14e5f8be022c0dc099ef98980f3fc99f403ca565ab1f3addaee5b
+
+PKG_MAINTAINER:=Eneas U de Queiroz <cotequeiroz@gmail.com>
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=LICENSE
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).zip
-PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/d/$(PKG_NAME)
-PKG_HASH:=e14e5c4b207be3dffb200309e7ac7a48de1a2b3293f09eefedd9ab317c4d9a7f
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 include ../python-package.mk
+include ../python3-package.mk
+
+PKG_UNPACK:=$(HOST_TAR) -C $(PKG_BUILD_DIR) --strip-components=1 -xzf $(DL_DIR)/$(PKG_SOURCE)
 
-define Package/django-simple-captcha
+define Package/$(PKG_NAME)/Default
   SUBMENU:=Python
   SECTION:=lang
   CATEGORY:=Languages
   TITLE:=Simple Django captcha application
   URL:=https://github.com/mbi/django-simple-captcha
-  DEPENDS:=+python +python-six +python-django +pillow +django-ranged-response
+endef
+
+define Package/python-$(PKG_NAME)
+$(call Package/$(PKG_NAME)/Default)
+  DEPENDS:= \
+       +PACKAGE_python-$(PKG_NAME):python \
+       +PACKAGE_python-$(PKG_NAME):python-six \
+       +PACKAGE_python-$(PKG_NAME):python-django \
+       +PACKAGE_python-$(PKG_NAME):python-pillow \
+       +PACKAGE_python-$(PKG_NAME):python-django-ranged-response
   VARIANT:=python
 endef
 
-define Package/django-simple-captcha/description
+define Package/python-$(PKG_NAME)/description
   Django Simple Captcha is an extremely simple, yet highly customizable Django
   application to add captcha images to any Django form.
 endef
 
-$(eval $(call PyPackage,django-simple-captcha))
-$(eval $(call BuildPackage,django-simple-captcha))
-$(eval $(call BuildPackage,django-simple-captcha-src))
+define Package/python3-$(PKG_NAME)
+$(call Package/$(PKG_NAME)/Default)
+  DEPENDS:= \
+       +PACKAGE_python3-$(PKG_NAME):python3 \
+       +PACKAGE_python3-$(PKG_NAME):python3-six \
+       +PACKAGE_python3-$(PKG_NAME):python3-django \
+       +PACKAGE_python3-$(PKG_NAME):python3-pillow \
+       +PACKAGE_python3-$(PKG_NAME):python3-django-ranged-response
+  VARIANT:=python3
+endef
+
+define Package/python3-$(PKG_NAME)/description
+$(call define Package/python-$(PKG_NAME)/description)
+.
+(Variant for Python3)
+endef
+
+$(eval $(call PyPackage,python-$(PKG_NAME)))
+$(eval $(call BuildPackage,python-$(PKG_NAME)))
+$(eval $(call BuildPackage,python-$(PKG_NAME)-src))
+
+$(eval $(call Py3Package,python3-$(PKG_NAME)))
+$(eval $(call BuildPackage,python3-$(PKG_NAME)))
+$(eval $(call BuildPackage,python3-$(PKG_NAME)-src))
index d04413611d6466d3c0ed4ad6bfc4ae7ddb512752..5c7eb89487b595196cf0fbd2dfaff89fda4d8884 100644 (file)
@@ -30,7 +30,7 @@ SEAFILE_PYTHON_DEPENDS:= \
        simplejson chardet dateutil mysql pytz qrcode requests requests-oauthlib \
        django django-constance django-appconf django-compressor django-formtools \
        django-jsonfield django-picklefield django-postoffice django-restframework \
-       pillow
+       pillow django-simple-captcha
 
 define Package/seafile-seahub
   SECTION:=net
@@ -38,7 +38,7 @@ define Package/seafile-seahub
   TITLE:=Seafile server - seahub component
   URL:=https://seafile.com/
   DEPENDS:=+python \
-       +django-simple-captcha +django-statici18n +django-webpack-loader \
+       +django-statici18n +django-webpack-loader \
        +python-flup +gunicorn +openpyxl \
        $(foreach dep,$(SEAFILE_PYTHON_DEPENDS),+python-$(dep))
 endef