glib2: don't use libelf during host build
authorSebastian Kemper <sebastian_ml@gmx.net>
Mon, 9 Sep 2019 06:13:40 +0000 (08:13 +0200)
committertripolar <tripolar@users.noreply.github.com>
Mon, 9 Sep 2019 07:39:49 +0000 (09:39 +0200)
Since commit 2e490e7e46a4f6fbf66fa930a25c2991e24c0f83 tools/libelf
installs a pkgconfig file, which in turn is picked up during the glib2
host build. On the build bots the same occurs, although it so happens
that (sometimes?) libelf.h is not found and the host build fails. This
may be a timing issue specific to the build bots, as the header is in
fact installed by tools/libelf and I can't reproduce this here on my own
computer.

In any case, libelf (if detected) is only used by gresource. gresource
can be used without it. gresource is not used by OpenWrt's build system
(also not in openwrt/packages). So adding "--disable-libelf" to the host
configure args is not detrimental in any way and works around the issue
described above.

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
libs/glib2/Makefile

index a6405965771814ed85760e6d9495a0e260a69669..a9313371a0dfe64d0a99e915509139a5e7ba05ce 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=glib2
 PKG_VERSION:=2.58.3
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=glib-$(PKG_VERSION).tar.xz
 PKG_BUILD_DIR:=$(BUILD_DIR)/glib-$(PKG_VERSION)
@@ -47,6 +47,7 @@ endef
 TARGET_CFLAGS += -Wno-error=implicit-function-declaration
 
 HOST_CONFIGURE_ARGS += \
+       --disable-libelf \
        --disable-selinux \
        --with-libiconv=gnu \
        --with-pcre=internal \