rsync: add config option for zstd support
authorIan Leonard <antonlacon@gmail.com>
Fri, 14 Aug 2020 19:22:43 +0000 (12:22 -0700)
committerIan Leonard <antonlacon@gmail.com>
Sat, 3 Oct 2020 05:01:58 +0000 (22:01 -0700)
Signed-off-by: Ian Leonard <antonlacon@gmail.com>
net/rsync/Config.in
net/rsync/Makefile

index 5c297f400a418eb05053f12107e7bb34e75219d2..f5e3b67b13ebd0bf66f16e2e0b394ebf6edb1dfb 100644 (file)
@@ -12,4 +12,9 @@ if PACKAGE_rsync
                default y if USE_FS_ACL_ATTR
                default n
 
+       config RSYNC_zstd
+               bool
+               prompt "Enable zstd stream compression"
+               default n
+
 endif
index 6452def0ed46486fc92a1ffe7282473c7134da6a..a207455c67fa68d0180e941cc4ae722f6410c844 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rsync
 PKG_VERSION:=3.2.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://download.samba.org/pub/rsync/src
@@ -30,7 +30,7 @@ define Package/rsync
   CATEGORY:=Network
   SUBMENU:=File Transfer
   TITLE:=Fast remote file copy program (like rcp)
-  DEPENDS:=+libpopt +zlib +RSYNC_xattr:libattr +RSYNC_acl:libacl
+  DEPENDS:=+libpopt +zlib +RSYNC_xattr:libattr +RSYNC_acl:libacl +RSYNC_zstd:libzstd
   URL:=https://rsync.samba.org/
   MENU:=1
 endef
@@ -54,7 +54,7 @@ CONFIGURE_ARGS += \
        --disable-openssl \
        --disable-simd \
        --disable-xxhash \
-       --disable-zstd \
+       --$(if $(CONFIG_RSYNC_zstd),en,dis)able-zstd \
        --$(if $(CONFIG_RSYNC_xattr),en,dis)able-xattr-support \
        --$(if $(CONFIG_RSYNC_acl),en,dis)able-acl-support \
        $(if $(CONFIG_IPV6),,--disable-ipv6)