Import libogg from oldpackages
authorTed Hess <thess@kitschensync.net>
Thu, 17 Jul 2014 20:52:21 +0000 (16:52 -0400)
committerTed Hess <thess@kitschensync.net>
Thu, 17 Jul 2014 22:04:56 +0000 (18:04 -0400)
libs/libogg/Makefile [new file with mode: 0644]

diff --git a/libs/libogg/Makefile b/libs/libogg/Makefile
new file mode 100644 (file)
index 0000000..7b3f588
--- /dev/null
@@ -0,0 +1,58 @@
+#
+# Copyright (C) 2008-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libogg
+PKG_VERSION:=1.3.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=http://downloads.xiph.org/releases/ogg/
+PKG_MD5SUM:=ca25d8da0ddfc8c6cbbf78d847a209fe
+
+PKG_LICENSE:=BSD-3c
+PKG_LICENSE_FILES:=COPYING
+
+PKG_FIXUP:=autoreconf
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libogg
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=libogg
+  URL:=http://xiph.org/ogg/
+endef
+
+define Package/libogg/description
+Ogg project codecs use the Ogg bitstream format to arrange the raw,
+compressed bitstream into a more robust, useful form.  For example,
+the Ogg bitstream makes seeking, time stamping and error recovery
+possible, as well as mixing several sepearate, concurrent media
+streams into a single physical bitstream.
+endef
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include/ogg/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/ogg/* $(1)/usr/include/ogg/
+       $(INSTALL_DIR) $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.{so*,a,la} $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* $(1)/usr/lib/pkgconfig/
+       $(INSTALL_DIR) $(1)/usr/share/aclocal/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/aclocal/* $(1)/usr/share/aclocal/
+endef
+
+define Package/libogg/install
+       $(INSTALL_DIR) $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libogg))