glibs: revert "fix compilation with Alpine Linux"
authorRosen Penev <rosenp@gmail.com>
Fri, 1 Apr 2022 19:14:43 +0000 (12:14 -0700)
committerRosen Penev <rosenp@gmail.com>
Wed, 13 Apr 2022 07:31:39 +0000 (00:31 -0700)
This reverts commit 0ce744202ad2a2feaa3b841ce934765416d1339e.

Broken everywhere else. A better solution will need to be found.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
(cherry picked from commit 2784618ab57a9533a615eb139e87b920f733c002)

libs/glib2/Makefile
libs/glib2/patches-host/001-musl-libintl.patch [deleted file]

index 5b225de8096fd348179a28c874001f76c30271fc..a18732b80ced49ba4bdd6d251d502e42db802903 100644 (file)
@@ -27,8 +27,6 @@ HOST_BUILD_DEPENDS:=libiconv/host libffi/host pcre/host
 PKG_CONFIG_DEPENDS:=CONFIG_BUILD_NLS
 PKG_INSTALL:=1
 
-HOST_PATCH_DIR:=./patches-host
-
 include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/nls.mk
@@ -46,6 +44,7 @@ define Package/glib2/description
   The GLib library of C routines
 endef
 
+HOST_LDFLAGS += -Wl,-rpath,$(STAGING_DIR_HOSTPKG)/lib
 TARGET_CFLAGS += -ffunction-sections -fdata-sections
 TARGET_LDFLAGS += -Wl,--gc-sections $(if $(INTL_FULL),-lintl)
 
diff --git a/libs/glib2/patches-host/001-musl-libintl.patch b/libs/glib2/patches-host/001-musl-libintl.patch
deleted file mode 100644 (file)
index db224f5..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/meson.build
-+++ b/meson.build
-@@ -2047,9 +2047,6 @@ endif
- # FIXME: glib-gettext.m4 has much more checks to detect broken/uncompatible
- # implementations. This could be extended if issues are found in some platforms.
- libintl_deps = []
--if cc.has_function('ngettext', args : osx_ldflags)
--  have_bind_textdomain_codeset = cc.has_function('bind_textdomain_codeset')
--else
-   # First just find the bare library.
-   libintl = cc.find_library('intl', required : false)
-   # The bare library probably won't link without help if it's static.
-@@ -2081,7 +2078,6 @@ else
-     have_bind_textdomain_codeset = cc.has_function('bind_textdomain_codeset', args : osx_ldflags,
-                                                    dependencies : libintl_deps)
-   endif
--endif
- glib_conf.set('HAVE_BIND_TEXTDOMAIN_CODESET', have_bind_textdomain_codeset)