Upgrade lighttpd to 1.4.11, fixes the mod_proxy issue, closes #652
authorFlorian Fainelli <florian@openwrt.org>
Tue, 25 Jul 2006 11:40:45 +0000 (11:40 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 25 Jul 2006 11:40:45 +0000 (11:40 +0000)
SVN-Revision: 4276

openwrt/package/lighttpd/Makefile
openwrt/package/lighttpd/patches/500-configure_cross.patch

index 254a29dcbc1b55c70c3b93178be3331dc73ffcfa..4636c73cf62af9da6367e0a65742be2cf1c64698 100644 (file)
@@ -3,9 +3,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lighttpd
-PKG_VERSION:=1.3.13
+PKG_VERSION:=1.4.11
 PKG_RELEASE:=2
-PKG_MD5SUM:=2f017b936be376ad6f6c2ee26db93467
+PKG_MD5SUM:=f55eebb9815c94a7de35906bb557ecd3
 
 PKG_SOURCE_URL:=http://www.lighttpd.net/download/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
index cf24343ba6eed084bfa49ffa755ed488a4b1775b..101a1f974b5b9e10d54e71f7afd43c1f6bd28ce9 100644 (file)
@@ -1,37 +1,37 @@
-diff -ruN lighttpd-1.3.13-old/configure lighttpd-1.3.13-new/configure
---- lighttpd-1.3.13-old/configure      2005-03-06 11:53:51.000000000 +0100
-+++ lighttpd-1.3.13-new/configure      2005-09-01 09:10:36.000000000 +0200
-@@ -22623,7 +22623,7 @@
- fi
--if test "x$cross_compiling" = xno; then
-+#if test "x$cross_compiling" = xno; then
-   # Extract the first word of "pcre-config", so it can be a program name with args.
- set dummy pcre-config; ac_word=$2
- echo "$as_me:$LINENO: checking for $ac_word" >&5
-@@ -22882,7 +22882,7 @@
+diff -urN lighttpd-1.4.11/configure lighttpd-1.4.11.new/configure
+--- lighttpd-1.4.11/configure  2006-03-07 13:21:15.000000000 +0100
++++ lighttpd-1.4.11.new/configure      2006-07-25 13:27:58.000000000 +0200
+@@ -24524,7 +24524,7 @@
  
      LIBS="$OLDLIBS"
-   fi
 -fi
 +#fi
  
+ echo "$as_me:$LINENO: checking for perl regular expressions support" >&5
+ echo $ECHO_N "checking for perl regular expressions support... $ECHO_C" >&6
+@@ -24539,7 +24539,7 @@
+ echo "$as_me:$LINENO: result: $WITH_PCRE" >&5
+ echo "${ECHO_T}$WITH_PCRE" >&6
  
-diff -ruN lighttpd-1.3.13-old/configure.in lighttpd-1.3.13-new/configure.in
---- lighttpd-1.3.13-old/configure.in   2005-03-06 11:53:39.000000000 +0100
-+++ lighttpd-1.3.13-new/configure.in   2005-09-01 08:44:12.000000000 +0200
-@@ -207,7 +207,7 @@
-     AC_SUBST(SSL_LIB)
- fi
--if test "x$cross_compiling" = xno; then
-+#if test "x$cross_compiling" = xno; then
+-if test "x$cross_compiling" = xno -a "$WITH_PCRE" != "no"; then
++#if test "x$cross_compiling" = xno -a "$WITH_PCRE" != "no"; then
+   # Extract the first word of "pcre-config", so it can be a program name with args.
+ set dummy pcre-config; ac_word=$2
+ echo "$as_me:$LINENO: checking for $ac_word" >&5
+diff -urN lighttpd-1.4.11/configure.in lighttpd-1.4.11.new/configure.in
+--- lighttpd-1.4.11/configure.in       2006-03-04 15:32:38.000000000 +0100
++++ lighttpd-1.4.11.new/configure.in   2006-07-25 13:28:07.000000000 +0200
+@@ -250,7 +250,7 @@
+     [WITH_PCRE=$withval],[WITH_PCRE=yes])
+ AC_MSG_RESULT([$WITH_PCRE])
+-if test "x$cross_compiling" = xno -a "$WITH_PCRE" != "no"; then
++#if test "x$cross_compiling" = xno -a "$WITH_PCRE" != "no"; then
    AC_PATH_PROG(PCRECONFIG, pcre-config)
  
    if test x"$PCRECONFIG" != x; then 
-@@ -223,7 +223,7 @@
+@@ -266,7 +266,7 @@
      ])
      LIBS="$OLDLIBS"
    fi