nfs-kernel-server: fix missing host symbol res_querydomain/missing-include-dir
authorAndy Walsh <andy.walsh44+github@gmail.com>
Tue, 7 Aug 2018 14:16:17 +0000 (16:16 +0200)
committertripolar <tripolar@users.noreply.github.com>
Sat, 27 Apr 2019 17:53:33 +0000 (19:53 +0200)
Signed-off-by: Andy Walsh <andy.walsh44+github@gmail.com>
(cherry picked from commit 19dfe3b173609bed21496012a8c859f714351db8)

net/nfs-kernel-server/Makefile

index 136ef52d6ec9b236269e885077932d10b5391bbc..763a634a3655be1f58c166076b6039f997722ce4 100644 (file)
@@ -72,7 +72,8 @@ TARGET_CFLAGS += -Wno-error=implicit-function-declaration \
                 -Wno-error=strict-prototypes \
                 -Wno-error=incompatible-pointer-types \
                 -Wno-error=format-security \
-                -Wno-error=undef
+                -Wno-error=undef \
+                -Wno-error=missing-include-dirs
 
 TARGET_LDFLAGS += -Wl,-rpath-link=$(STAGING_DIR)/usr/lib $(LIBRPC) \
                  -L$(STAGING_DIR)/usr/lib/libevent
@@ -100,7 +101,8 @@ MAKE_FLAGS += \
        RPCGEN_PATH=$(STAGING_DIR_HOSTPKG)/bin/rpcgen \
        RPCGEN=$(STAGING_DIR_HOSTPKG)/bin/rpcgen
 
-HOST_CFLAGS += -Dlinux
+HOST_CFLAGS += -Dlinux \
+       -Wno-error=missing-include-dirs
 
 HOST_CONFIGURE_ARGS += \
        --disable-gss \
@@ -117,6 +119,7 @@ HOST_CONFIGURE_VARS += \
        ac_cv_header_event_h=yes \
        ac_cv_header_nfsidmap_h=yes \
        ac_cv_header_blkid_blkid_h=yes \
+       ac_cv_lib_resolv___res_querydomain=yes \
        GSSGLUE_CFLAGS=" " \
        GSSGLUE_LIBS=" " \
        RPCSECGSS_CFLAGS=" " \