python3-texttable: add a new package
authorJavier Marcet <javier@marcet.info>
Sun, 19 Apr 2020 21:45:53 +0000 (23:45 +0200)
committerJavier Marcet <javier@marcet.info>
Mon, 8 Jun 2020 11:50:47 +0000 (13:50 +0200)
Signed-off-by: Javier Marcet <javier@marcet.info>
lang/python/python-texttable/Makefile [new file with mode: 0644]

diff --git a/lang/python/python-texttable/Makefile b/lang/python/python-texttable/Makefile
new file mode 100644 (file)
index 0000000..9600618
--- /dev/null
@@ -0,0 +1,34 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-texttable
+PKG_VERSION:=1.6.2
+PKG_RELEASE:=1
+
+PYPI_NAME:=texttable
+PKG_HASH:=eff3703781fbc7750125f50e10f001195174f13825a92a45e9403037d539b4f4
+
+PKG_MAINTAINER:=Javier Marcet <javier@marcet.info>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-texttable
+  SECTION:=lang
+  CATEGORY:=Languages
+  SUBMENU:=Python
+  TITLE:=Module for creating simple ASCII tables
+  URL:=https://github.com/foutaise/texttable/
+  DEPENDS:=+python3-light +python3-codecs
+  VARIANT:=python3
+endef
+
+define Package/python3-texttable/description
+  Module for creating simple ASCII tables
+endef
+
+$(eval $(call Py3Package,python3-texttable))
+$(eval $(call BuildPackage,python3-texttable))
+$(eval $(call BuildPackage,python3-texttable-src))