projects
/
feed
/
packages.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
8905f98
)
dockerd: fix compilation with glibc
author
Liang Yang
<ggg17226@gmail.com>
Sat, 30 Apr 2022 17:30:47 +0000
(
01:30
+0800)
committer
Rosen Penev
<rosenp@gmail.com>
Sun, 15 May 2022 14:57:39 +0000
(07:57 -0700)
Signed-off-by: Liang Yang <ggg17226@gmail.com>
(cherry picked from commit
9963312067185d7d47970d2abfb59b6c1a7bfdd5
)
utils/dockerd/Makefile
patch
|
blob
|
history
diff --git
a/utils/dockerd/Makefile
b/utils/dockerd/Makefile
index 99d6aa490b2278d1b775c8d5fa2cb80a4a1d1019..c2cc43db72886e8cc943cc71fe84fe832edee72e 100644
(file)
--- a/
utils/dockerd/Makefile
+++ b/
utils/dockerd/Makefile
@@
-63,6
+63,7
@@
endef
GO_PKG_BUILD_VARS += GO111MODULE=auto
TAR_OPTIONS:=--strip-components 1 $(TAR_OPTIONS)
TAR_CMD=$(HOST_TAR) -C $(1) $(TAR_OPTIONS)
+TARGET_LDFLAGS += $(if $(CONFIG_USE_GLIBC),-lc -lgcc_eh)
# $(1) = path to dependent package 'Makefile'
# $(2) = relevant dependency '.installer' file