mpd: replace mpg123 with libmad
authorRosen Penev <rosenp@gmail.com>
Fri, 31 Jan 2020 05:07:25 +0000 (21:07 -0800)
committerRosen Penev <rosenp@gmail.com>
Tue, 4 Feb 2020 04:28:04 +0000 (20:28 -0800)
libmad is almost half the size of libmpg123. The docoding is done with
integers instead of floats.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
sound/mpd/Makefile

index f732f8b61eda66a5c54940093f6b1ef3edf69b76..0cb361439f15ffc8a0d543c16732e722fcc76027 100644 (file)
@@ -64,7 +64,7 @@ endef
 define Package/mpd-mini
 $(call Package/mpd/Default)
   TITLE+= (mini)
-  DEPENDS+= +libmpg123 +libvorbisidec
+  DEPENDS+= +libmad +libvorbisidec
   PROVIDES:=mpd
   VARIANT:=mini
 endef
@@ -132,7 +132,7 @@ MESON_ARGS += \
        -Dflac=enabled \
        -Dfluidsynth=disabled \
        -Dgme=disabled \
-       -Dmad=disabled \
+       -Dmpg123=disabled \
        -Dmikmod=disabled \
        -Dmodplug=disabled \
        -Dmpcdec=disabled \
@@ -174,7 +174,7 @@ ifeq ($(BUILD_VARIANT),full)
        -Dsoundcloud=enabled \
        -Did3tag=enabled \
        -Dffmpeg=enabled \
-       -Dmpg123=disabled \
+       -Dmad=disabled \
        -Dtremor=disabled \
        -Dvorbis=enabled \
        -Dfifo=true \
@@ -194,7 +194,7 @@ ifeq ($(BUILD_VARIANT),mini)
        -Dsoundcloud=disabled \
        -Did3tag=disabled \
        -Dffmpeg=disabled \
-       -Dmpg123=enabled \
+       -Dmad=enabled \
        -Dtremor=enabled \
        -Dvorbis=disabled \
        -Dfifo=false \