vsftpd: fix compilation with musl 1.2.4
authorTianling Shen <cnsztl@immortalwrt.org>
Thu, 22 Jun 2023 06:27:18 +0000 (14:27 +0800)
committerTianling Shen <cnsztl@immortalwrt.org>
Fri, 23 Jun 2023 06:16:48 +0000 (14:16 +0800)
musl 1.2.4 deprecated legacy "LFS64" ("large file support") interfaces so
just having _GNU_SOURCE defined is not enough anymore.

Manually pass -D_LARGEFILE64_SOURCE to allow to keep using LFS64 definitions.

Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
(cherry picked from commit a9cda9150232c4907607a3f19ad1d0833541bc89)

net/vsftpd/Makefile

index ad74c7f928c409df2bccad34024c116336212eb0..52853052ff5fcb01b171656a46ea8f66b3da83db 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vsftpd
 PKG_VERSION:=3.0.5
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://security.appspot.com/downloads/
@@ -52,6 +52,7 @@ Package/vsftpd-tls/conffiles=$(Package/vsftpd/conffiles)
 
 ifneq ($(CONFIG_USE_MUSL),)
   NLSSTRING:=-lcrypt
+  TARGET_CFLAGS += -D_LARGEFILE64_SOURCE
 else ifneq ($(CONFIG_USE_GLIBC),)
   NLSSTRING:=-lcrypt
 else