lcdproc: fix build on macos
authorSergey V. Lobanov <sergey@lobanov.in>
Wed, 12 Jan 2022 15:12:46 +0000 (18:12 +0300)
committerSergey V. Lobanov <sergey@lobanov.in>
Wed, 12 Jan 2022 15:12:46 +0000 (18:12 +0300)
./configure script detects mtab file and fails build if mtab is not
found on build host. It is not required for OpenWrt build due to
mtab is always /etc/mtab on OpenWrt

MacOS doesn't have mtab file so disable it via ac_cv_mtab_file var

Signed-off-by: Sergey V. Lobanov <sergey@lobanov.in>
utils/lcdproc/Makefile

index b34a2d836898539e1580677adfa005c838c15a79..34ea2e1b65448ed4d56211399c2fc1eb8d828ae4 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lcdproc
 PKG_VERSION:=0.5.9
-PKG_RELEASE:=5
+PKG_RELEASE:=6
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/lcdproc/lcdproc/releases/download/v$(PKG_VERSION)/
@@ -109,6 +109,9 @@ This package contains display drivers with external dependencies:
 $(LCDPROC_OTHER_DRIVERS_TEXT)
 endef
 
+CONFIGURE_VARS += \
+       ac_cv_mtab_file="/etc/mtab"
+
 CONFIGURE_ARGS += \
        --disable-libX11 \
        --disable-libhid \