kernel: modules: add support for led-group-multicolor
authorJonathan Brophy <professor_jonny@hotmail.com>
Tue, 10 Sep 2024 09:43:23 +0000 (21:43 +1200)
committerJohn Crispin <john@phrozen.org>
Thu, 12 Dec 2024 11:17:01 +0000 (12:17 +0100)
This option enables support for monochrome LEDs that are grouped into multicolor
LEDs which is useful in the case where LEDs of different colors are physically
grouped in a single multi-color LED and driven by a controller that doesn't have
multi-color support.

Signed-off-by: Jonathan Brophy <professor_jonny@hotmail.com>
Link: https://github.com/openwrt/openwrt/pull/16397
Signed-off-by: John Crispin <john@phrozen.org>
package/kernel/linux/modules/leds.mk

index 0c42895bb2f3c99d818f567cfc28158d5a04fa4c..f6f74283eeec4a6799eacd037b07481bd34cb33d 100644 (file)
@@ -22,6 +22,25 @@ endef
 
 $(eval $(call KernelPackage,leds-gpio))
 
+define KernelPackage/led-group-multicolor
+        SUBMENU:=$(LEDS_MENU)
+        TITLE:=LEDs group multi-color support
+        KCONFIG:= \
+            CONFIG_LEDS_CLASS_MULTICOLOR \
+            CONFIG_LEDS_GROUP_MULTICOLOR
+         FILES:=$(LINUX_DIR)/drivers/leds/rgb/leds-group-multicolor.ko
+        AUTOLOAD:=$(call AutoProbe,led-group-multi-color)
+endef
+
+define KernelPackage/led-group-multi-color/description
+        This option enables support for monochrome LEDs that are grouped
+        into multicolor LEDs which is useful in the case where LEDs of
+        different colors are physically grouped in a single multi-color LED
+        and driven by a controller that does not have multi-color support.
+endef
+
+$(eval $(call KernelPackage,led-group-multi-color))
+
 LED_TRIGGER_DIR=$(LINUX_DIR)/drivers/leds/trigger
 
 define KernelPackage/ledtrig-activity
@@ -313,4 +332,4 @@ define KernelPackage/leds-lp5562/description
  LED controllers.
 endef
 
-$(eval $(call KernelPackage,leds-lp5562))
\ No newline at end of file
+$(eval $(call KernelPackage,leds-lp5562))