python3: Fix unnecessary linking with libbsd
authorJeffery To <jeffery.to@gmail.com>
Thu, 25 May 2023 04:01:17 +0000 (12:01 +0800)
committerJeffery To <jeffery.to@gmail.com>
Thu, 25 May 2023 05:42:00 +0000 (13:42 +0800)
configure will try to link with libbsd for the flock function, even when
flock is available without it.

Fixes: https://github.com/openwrt/packages/issues/21161
Fixes: 2445fe9fb25e ("python3: Update to 3.11.3, refresh/redo patches")
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
lang/python/python3/Makefile

index 0a3e4cbc5c35770dd55e79ee7615f184ac7ec954..020d88a6ec3113226719bd2e390e316d4414e4e8 100644 (file)
@@ -153,6 +153,11 @@ CONFIGURE_VARS += \
        ac_cv_file__dev_ptc=no \
        ac_cv_file__dev_ptmx=yes
 
+# Do not link with libbsd for flock
+# https://github.com/openwrt/packages/issues/21161
+CONFIGURE_VARS += \
+       ac_cv_lib_bsd_flock=no
+
 # Disable stdlib modules
 # Check for a better way in the future: https://github.com/python/cpython/issues/98558
 CONFIGURE_VARS += \