unixodbc: Change host build directories to be target-specific
authorJeffery To <jeffery.to@gmail.com>
Fri, 27 Oct 2023 06:18:54 +0000 (14:18 +0800)
committerRosen Penev <rosenp@gmail.com>
Mon, 30 Oct 2023 20:25:58 +0000 (13:25 -0700)
Since the host odbc_config returns target-specific information, it
should be built and placed into target-specific locations.

This changes HOST_BUILD_DIR to be in $(BUILD_DIR)/host, and installs
odbc_config inside $(STAGING_DIR)/host.

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
libs/unixodbc/Makefile

index bdc52e713d4be7609b6f425178aba164cdd32c80..c99b8e4f6922aa8730f829795b462c5eece47ef4 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=unixodbc
 PKG_VERSION:=2.3.9
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=unixODBC-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.unixodbc.org
@@ -20,7 +20,7 @@ PKG_LICENSE:=prog GPL libs LGPL
 PKG_CPE_ID:=cpe:/a:unixodbc:unixodbc
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/unixODBC-$(PKG_VERSION)
-HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/unixODBC-$(PKG_VERSION)
+HOST_BUILD_DIR:=$(BUILD_DIR)/host/unixODBC-$(PKG_VERSION)
 HOST_BUILD_DEPENDS:=unixodbc
 
 PKG_FIXUP:=autoreconf
@@ -150,8 +150,8 @@ define Host/Compile
 endef
 
 define Host/Install
-       $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
-       $(INSTALL_BIN) $(HOST_BUILD_DIR)/exe/odbc_config $(STAGING_DIR_HOST)/bin
+       $(INSTALL_DIR) $(STAGING_DIR)/host/bin
+       $(INSTALL_BIN) $(HOST_BUILD_DIR)/exe/odbc_config $(STAGING_DIR)/host/bin/
 endef
 
 $(eval $(call BuildPackage,unixodbc))