sane-backends: update to 1.0.28 (WIP)
authorLuiz Angelo Daros de Luca <luizluca@gmail.com>
Mon, 28 Oct 2019 02:58:34 +0000 (23:58 -0300)
committerLuiz Angelo Daros de Luca <luizluca@gmail.com>
Fri, 1 Nov 2019 07:21:14 +0000 (04:21 -0300)
Just Need runtime tests

* libsane dependency on libusb moved to those drivers that requires it
* clean up some ./configure args
* added saned-ricoh2 for new backend
* enabled saned-gphoto2 (after c8fbe26c532aced97ab8a4d42f1289db2a3e6d65)
* disabled kvs40xx and mustek_usb2 that requires pthread while the issue is
not solved (https://gitlab.com/sane-project/backends/issues/153)
* patches refreshed:
 - 002-remove-uneeded.patch
* patches dropped:
 - 031-fix_uclibc.patch
 - 050-remove_linked_libs_for_unused_preload.patch (with --disable-preload)

Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
utils/sane-backends/Makefile
utils/sane-backends/files/etc/xinetd.d/sane-port [deleted file]
utils/sane-backends/files/saned.sbin [new file with mode: 0755]
utils/sane-backends/files/saned.xinetd [new file with mode: 0644]
utils/sane-backends/files/usr/sbin/saned [deleted file]
utils/sane-backends/patches/002-remove-uneeded.patch
utils/sane-backends/patches/031-fix_uclibc.patch [deleted file]
utils/sane-backends/patches/050-remove_linked_libs_for_unused_preload.patch [deleted file]

index a67bae33f6702b31d60c0c4e331886e344b93000..b9d2af214fb4591741f44bc961355ee046a2024e 100644 (file)
@@ -9,12 +9,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sane-backends
-PKG_VERSION:=1.0.27
-PKG_RELEASE:=4
+PKG_VERSION:=1.0.28
+PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://fossies.org/linux/misc \
-    https://alioth.debian.org/frs/download.php/file/4146/
-PKG_HASH:=293747bf37275c424ebb2c833f8588601a60b2f9653945d5a3194875355e36c9
+PKG_SOURCE_URL:=https://gitlab.com/sane-project/backends/uploads/9e718daff347826f4cfe21126c8d5091/
+PKG_HASH:=31260f3f72d82ac1661c62c5a4468410b89fb2b4a811dabbfcc0350c1346de03
 PKG_MAINTAINER:=Luiz Angelo Daros de Luca <luizluca@gmail.com>
 PKG_LICENSE:=GPL-2.0 GPL-2.0-or-later
 PKG_LICENSE_FILES:=COPYING LICENSE
@@ -137,7 +136,6 @@ define Package/libsane
   $(call Package/sane-backends/Default)
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+libusb-1.0
   TITLE+= (libraries)
 endef
 
@@ -159,16 +157,15 @@ $(call Package/sane-backends/Default/description)
 This package contains the SANE frontends.
 endef
 
-TARGET_LDFLAGS += \
-       -Wl,-rpath-link $(STAGING_DIR)/usr/lib \
-       -Wl,-rpath-link $(PKG_BUILD_DIR)/backend/.libs
-
 CONFIGURE_ARGS+= \
        --enable-shared \
        --enable-static \
-       --without-gphoto2 \
-       --without-snmp
+       --disable-preload \
+       --without-snmp \
+       --disable-avahi \
+       --disable-locking \
 
+# ./configure does not even try to detect mmap if crosscompiling
 CONFIGURE_VARS+= \
     ac_cv_func_mmap_fixed_mapped="yes" \
 
@@ -183,6 +180,7 @@ define Package/libsane/install
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/sane/libsane-dll.so.* $(1)/usr/lib/sane/
        $(INSTALL_DIR) $(1)/etc/sane.d/dll.d
        $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/sane.d/dll.conf $(1)/etc/sane.d/
+       chmod 0755 $(1)/etc/sane.d/dll.conf
 endef
 
 define Package/libsane/conffiles
@@ -192,12 +190,13 @@ endef
 define Package/sane-daemon/install
        $(INSTALL_DIR) $(1)/etc/sane.d
        $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/sane.d/saned.conf $(1)/etc/sane.d/
+       chmod 0755 $(1)/etc/sane.d/saned.conf
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) ./files/usr/sbin/saned $(1)/usr/sbin/saned
+       $(INSTALL_BIN) ./files/saned.sbin $(1)/usr/sbin/saned
        $(INSTALL_DIR) $(1)/usr/lib/sane/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/saned $(1)/usr/lib/sane/saned
        $(INSTALL_DIR) $(1)/etc/xinetd.d
-       $(CP) ./files/etc/xinetd.d/sane-port $(1)/etc/xinetd.d/sane-port
+       $(INSTALL_CONF) ./files/saned.xinetd $(1)/etc/xinetd.d/sane-port
 endef
 
 define Package/sane-daemon/conffiles
@@ -246,6 +245,7 @@ This package contains the SANE backend for $(2).
        if [ -f "$(PKG_INSTALL_DIR)/etc/sane.d/$(1).conf" ]; then \
          $(INSTALL_DIR) $$(1)/etc/sane.d ; \
          $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/sane.d/$(1).conf $$(1)/etc/sane.d/; \
+         chmod 0755 $$(1)/etc/sane.d/$(1).conf ; \
        fi
        $(INSTALL_DIR) $$(1)/usr/lib/sane
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/sane/libsane-$(1).so.* $$(1)/usr/lib/sane/
@@ -268,92 +268,97 @@ $(eval $(call SaneBackend,abaton,Abaton flatbed scanners))
 $(eval $(call SaneBackend,agfafocus,AGFA Focus flatbed scanners))
 $(eval $(call SaneBackend,apple,Apple flatbed scanners))
 $(eval $(call SaneBackend,artec,Artec flatbed scanners))
-$(eval $(call SaneBackend,artec_eplus48u,Artec E+ 48U and re-badged models))
+$(eval $(call SaneBackend,artec_eplus48u,Artec E+ 48U and re-badged models,+libusb-1.0))
 $(eval $(call SaneBackend,as6e,Artec AS6E parallel port interface scanner))
-$(eval $(call SaneBackend,avision,Avision and Avision OEM scanners and possibly more flatbed and film scanners))
+$(eval $(call SaneBackend,avision,Avision and Avision OEM scanners and possibly more flatbed and film scanners,+libusb-1.0))
 $(eval $(call SaneBackend,bh,Bell+Howell Copiscan II series document scanners))
-$(eval $(call SaneBackend,canon,Canon SCSI scanners))
-$(eval $(call SaneBackend,canon630u,the Canon 630u USB flatbed scanner))
-$(eval $(call SaneBackend,canon_dr,Canon DR-series scanners))
+$(eval $(call SaneBackend,canon,Canon SCSI scanners,+libusb-1.0))
+$(eval $(call SaneBackend,canon630u,the Canon 630u USB flatbed scanner,+libusb-1.0))
+$(eval $(call SaneBackend,canon_dr,Canon DR-series scanners,+libusb-1.0))
 # Depends on libieee1284
 #$(eval $(call SaneBackend,canon_pp,Canon CanoScan Parallel Port flatbed scanners,+libieee1284))
-$(eval $(call SaneBackend,cardscan,Corex CardScan usb scanners))
-$(eval $(call SaneBackend,coolscan,Nikon film-scanners))
-$(eval $(call SaneBackend,coolscan2,Nikon Coolscan film scanners))
-$(eval $(call SaneBackend,coolscan3,Nikon Coolscan film scanners))
+$(eval $(call SaneBackend,cardscan,Corex CardScan usb scanners,+libusb-1.0))
+$(eval $(call SaneBackend,coolscan,Nikon film-scanners,+libusb-1.0))
+$(eval $(call SaneBackend,coolscan2,Nikon Coolscan film scanners,+libusb-1.0))
+$(eval $(call SaneBackend,coolscan3,Nikon Coolscan film scanners,+libusb-1.0))
 $(eval $(call SaneBackend,dc210,Kodak DC210 Digital Camera,+libjpeg))
 $(eval $(call SaneBackend,dc240,Kodak DC240 Digital Camera,+libjpeg))
 $(eval $(call SaneBackend,dc25,Kodak DC20/DC25 Digital Cameras))
-$(eval $(call SaneBackend,dell1600n_net,Dell 1600n,+libtiff))
+$(eval $(call SaneBackend,dell1600n_net,Dell 1600n,+libtiff +libjpeg))
 $(eval $(call SaneBackend,dmc,Polaroid Digital Microscope Camera))
-$(eval $(call SaneBackend,epjitsu,Epson-based Fujitsu USB scanners))
-$(eval $(call SaneBackend,epson,EPSON scanners))
-$(eval $(call SaneBackend,epsonds,EPSON scanners,+libjpeg)) ####
-$(eval $(call SaneBackend,epson2,EPSON scanners))
-$(eval $(call SaneBackend,fujitsu,Fujitsu flatbed and ADF scanners))
-$(eval $(call SaneBackend,genesys,GL646 GL841 GL843 GL847 and GL124 based USB flatbed scanners))
-#$(eval $(call SaneBackend,gphoto2,digital cameras supported by gphoto2,+libjpeg))
-$(eval $(call SaneBackend,gt68xx,GT-68XX based USB flatbed scanners))
-$(eval $(call SaneBackend,hp,HP ScanJet scanners))
-$(eval $(call SaneBackend,hp3500,Hewlett-Packard ScanJet 3500 series scanners))
-$(eval $(call SaneBackend,hp3900,RTS8822 chipset based scanners,+libtiff))
-$(eval $(call SaneBackend,hp4200,Hewlett-Packard 4200 scanners))
-$(eval $(call SaneBackend,hp5400,Hewlett-Packard 54XX scanners))
-$(eval $(call SaneBackend,hp5590,Hewlett-Packard 4500C/4570C/5500C/5550C/5590/7650 Workgroup/Document scanners))
-$(eval $(call SaneBackend,hpljm1005,Hewlett-Packard LaserJet M1005 MFP Scanner))
+$(eval $(call SaneBackend,epjitsu,Epson-based Fujitsu USB scanners,+libusb-1.0))
+$(eval $(call SaneBackend,epson,EPSON scanners,+libusb-1.0))
+$(eval $(call SaneBackend,epsonds,EPSON scanners,+libjpeg +libusb-1.0)) ####
+$(eval $(call SaneBackend,epson2,EPSON scanners,+libusb-1.0))
+$(eval $(call SaneBackend,fujitsu,Fujitsu flatbed and ADF scanners,+libusb-1.0))
+$(eval $(call SaneBackend,genesys,GL646 GL841 GL843 GL847 and GL124 based USB flatbed scanners,+libstdcpp +libusb-1.0))
+$(eval $(call SaneBackend,gphoto2,digital cameras supported by gphoto2,+libjpeg +libgphoto2))
+$(eval $(call SaneBackend,gt68xx,GT-68XX based USB flatbed scanners,+libusb-1.0))
+$(eval $(call SaneBackend,hp,HP ScanJet scanners,+libusb-1.0))
+$(eval $(call SaneBackend,hp3500,Hewlett-Packard ScanJet 3500 series scanners,+libusb-1.0))
+$(eval $(call SaneBackend,hp3900,RTS8822 chipset based scanners,+libtiff +libusb-1.0))
+$(eval $(call SaneBackend,hp4200,Hewlett-Packard 4200 scanners,+libusb-1.0))
+$(eval $(call SaneBackend,hp5400,Hewlett-Packard 54XX scanners,+libusb-1.0))
+$(eval $(call SaneBackend,hp5590,Hewlett-Packard 4500C/4570C/5500C/5550C/5590/7650 Workgroup/Document scanners,+libusb-1.0))
+$(eval $(call SaneBackend,hpljm1005,Hewlett-Packard LaserJet M1005 MFP Scanner,+libusb-1.0))
 # Depends on libieee1284
 #$(eval $(call SaneBackend,hpsj5s,HP ScanJet 5S sheet-fed scanner,+libieee1284))
 $(eval $(call SaneBackend,hs2p,Ricoh SCSI flatbed/ADF scanners))
 $(eval $(call SaneBackend,ibm,IBM and Ricoh SCSI flatbed scanners))
-$(eval $(call SaneBackend,kodak,big Kodak flatbed and ADF scanners))
-$(eval $(call SaneBackend,kodakaio,Kodak aio printer / scanners))
-$(eval $(call SaneBackend,kvs20xx,Panasonic KV-S20xxC USB/SCSI ADF scanners))
-$(eval $(call SaneBackend,kvs40xx,Panasonic KV-S40xxC USB/SCSI ADF scanners))
-$(eval $(call SaneBackend,kvs1025,Panasonic KV-S102xC USB ADF scanners))
+$(eval $(call SaneBackend,kodak,big Kodak flatbed and ADF scanners,+libusb-1.0))
+$(eval $(call SaneBackend,kodakaio,Kodak aio printer / scanners,+libusb-1.0))
+$(eval $(call SaneBackend,kvs1025,Panasonic KV-S102xC USB ADF scanners,+libusb-1.0))
+$(eval $(call SaneBackend,kvs20xx,Panasonic KV-S20xxC USB/SCSI ADF scanners,+libusb-1.0))
+# https://gitlab.com/sane-project/backends/issues/153
+#$(eval $(call SaneBackend,kvs40xx,Panasonic KV-S40xxC USB/SCSI ADF scanners,+libpthread +libusb-1.0))
 $(eval $(call SaneBackend,leo,LEO Technologies scanners))
-$(eval $(call SaneBackend,lexmark,Lexmark X1100/X1200 Series scanners))
-$(eval $(call SaneBackend,ma1509,Mustek BearPaw 1200F USB scanner))
-$(eval $(call SaneBackend,magicolor,KONICA MINOLTA magicolor scanners))
+$(eval $(call SaneBackend,lexmark,Lexmark X1100/X1200 Series scanners,+libusb-1.0))
+$(eval $(call SaneBackend,ma1509,Mustek BearPaw 1200F USB scanner,+libusb-1.0))
+$(eval $(call SaneBackend,magicolor,KONICA MINOLTA magicolor scanners,+libusb-1.0))
 $(eval $(call SaneBackend,matsushita,Panasonic KV-SS high speed scanners))
 $(eval $(call SaneBackend,microtek,Microtek scanners))
 $(eval $(call SaneBackend,microtek2,Microtek scanners with SCSI-2 command set))
 $(eval $(call SaneBackend,mustek,Mustek SCSI flatbed scanners and some other devices))
 # Depends on libieee1284
 #$(eval $(call SaneBackend,mustek_pp,Mustek parallel port flatbed scanners,+libieee1284))
-$(eval $(call SaneBackend,mustek_usb,Mustek USB flatbed scanners))
-$(eval $(call SaneBackend,mustek_usb2,SQ113 based USB flatbed scanners))
+$(eval $(call SaneBackend,mustek_usb,Mustek USB flatbed scanners,+libusb-1.0))
+# https://gitlab.com/sane-project/backends/issues/153
+#$(eval $(call SaneBackend,mustek_usb2,SQ113 based USB flatbed scanners,+libpthread +libusb-1.0))
 $(eval $(call SaneBackend,nec,NEC scanners))
 $(eval $(call SaneBackend,net,network backend))
-$(eval $(call SaneBackend,niash,scanners based on the NIASH chipset))
+$(eval $(call SaneBackend,niash,scanners based on the NIASH chipset,+libusb-1.0))
 $(eval $(call SaneBackend,p5,the Primax PagePartner))
 $(eval $(call SaneBackend,pie,PIE Devcom and AdLib SCSI flatbed scanners))
-$(eval $(call SaneBackend,pieusb,PIE Devcom and AdLib SCSI flatbed scanners)) #####
-$(eval $(call SaneBackend,pixma,Canon Multi-Function Printers and CanoScan Scanners))
-$(eval $(call SaneBackend,plustek,LM983[1/2/3] based USB flatbed scanners))
+$(eval $(call SaneBackend,pieusb,PIE Devcom and AdLib SCSI flatbed scanners,+libusb-1.0))
+# requires sys/scanio.h
+#$(eval $(call SaneBackend,pint,))
+$(eval $(call SaneBackend,pixma,Canon Multi-Function Printers and CanoScan Scanners,+libusb-1.0 +libjpeg))
+$(eval $(call SaneBackend,plustek,LM983[1/2/3] based USB flatbed scanners,+libusb-1.0))
 $(eval $(call SaneBackend,plustek_pp,Plustek parallel port flatbed scanners))
 $(eval $(call SaneBackend,qcam,Connectix QuickCam cameras,@(TARGET_x86||TARGET_x86_64)))
 $(eval $(call SaneBackend,ricoh,Ricoh flatbed scanners))
-$(eval $(call SaneBackend,rts8891,rts8891 based scanners))
+$(eval $(call SaneBackend,ricoh2,Ricoh2 flatbed scanners,+libusb-1.0))
+$(eval $(call SaneBackend,rts8891,rts8891 based scanners,+libusb-1.0))
 $(eval $(call SaneBackend,s9036,Siemens 9036 flatbed scanners))
 $(eval $(call SaneBackend,sceptre,SCEPTRE scanners))
 $(eval $(call SaneBackend,sharp,SHARP scanners))
-$(eval $(call SaneBackend,sm3600,Microtek scanners with M011 USB chip))
-$(eval $(call SaneBackend,sm3840,Microtek scanners with SCAN08 USB chip))
-$(eval $(call SaneBackend,snapscan,AGFA SnapScan flatbed scanners))
+$(eval $(call SaneBackend,sm3600,Microtek scanners with M011 USB chip,+libusb-1.0))
+$(eval $(call SaneBackend,sm3840,Microtek scanners with SCAN08 USB chip,+libusb-1.0))
+$(eval $(call SaneBackend,snapscan,AGFA SnapScan flatbed scanners,+libusb-1.0))
 $(eval $(call SaneBackend,sp15c,Fujitsu ScanPartner 15C flatbed scanner))
 $(eval $(call SaneBackend,st400,Siemens ST/Highscan flatbed scanners))
-$(eval $(call SaneBackend,stv680,STV680 cameras))
+$(eval $(call SaneBackend,stv680,STV680 cameras,+libusb-1.0))
 $(eval $(call SaneBackend,tamarack,Tamarack flatbed scanners))
 $(eval $(call SaneBackend,teco1,TECO / RELISYS scanners))
 $(eval $(call SaneBackend,teco2,TECO / RELISYS scanners))
 $(eval $(call SaneBackend,teco3,TECO / RELISYS scanners))
 $(eval $(call SaneBackend,test,testing frontends))
-$(eval $(call SaneBackend,u12,Plustek USB flatbed scanners based on older parport designs))
-$(eval $(call SaneBackend,umax,UMAX scanners))
-$(eval $(call SaneBackend,umax1220u,the UMAX Astra 1220U and similar scanners))
+$(eval $(call SaneBackend,u12,Plustek USB flatbed scanners based on older parport designs,+libusb-1.0))
+$(eval $(call SaneBackend,umax,UMAX scanners,+libusb-1.0))
+$(eval $(call SaneBackend,umax1220u,the UMAX Astra 1220U and similar scanners,+libusb-1.0))
 $(eval $(call SaneBackend,umax_pp,Umax Astra parallel port flatbed scanners))
-$(eval $(call SaneBackend,v4l,Video for Linux API,+libv4l +libjpeg))
-$(eval $(call SaneBackend,xerox_mfp,Xerox Phaser 3200MFP device,+libjpeg))
+$(eval $(call SaneBackend,v4l,Video for Linux API,+libv4l +libjpeg +libusb-1.0))
+$(eval $(call SaneBackend,xerox_mfp,Xerox Phaser 3200MFP device,+libjpeg +libusb-1.0))
 $(eval $(call BuildPackage,sane-backends))
 $(eval $(call BuildPackage,sane-backends-all))
 $(eval $(call BuildPackage,sane-frontends))
diff --git a/utils/sane-backends/files/etc/xinetd.d/sane-port b/utils/sane-backends/files/etc/xinetd.d/sane-port
deleted file mode 100644 (file)
index 9119973..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-# default: off
-# description: The saned provides scanner service via the network.  \
-#      Applications like kooka, xsane or xscanimage can use the remote \
-#      scanner. 
-service sane-port
-{
-       socket_type = stream
-       port        = 6566
-       wait        = no
-       user        = root
-       group       = root
-       server      = /usr/sbin/saned
-       disable     = yes
-}
diff --git a/utils/sane-backends/files/saned.sbin b/utils/sane-backends/files/saned.sbin
new file mode 100755 (executable)
index 0000000..7114926
--- /dev/null
@@ -0,0 +1,24 @@
+#!/bin/sh
+
+usblp_driver="/sys/bus/usb/drivers/usblp"
+
+inuse=""
+if [ -e /sys/bus/usb/devices ]; then
+       for usbdev_driver in /sys/bus/usb/devices/*/driver; do
+               [ -e "$usbdev_driver" ] || continue
+               [ "$(readlink -f "$usbdev_driver")" = "$usblp_driver" ] || continue
+               usbdev="${usbdev_driver%/*}"
+               inuse="$inuse ${usbdev##*/}"
+       done
+fi
+
+/usr/lib/sane/saned "$@"
+err=$?
+
+for usbdev in $inuse; do
+       [ -e "/sys/bus/usb/devices/$usbdev/driver" ] && continue
+       logger -t saned "binding device $usbdev back to usblp..."
+       printf '%s' "$usbdev" > "$usblp_driver/bind"
+done
+
+exit $err
diff --git a/utils/sane-backends/files/saned.xinetd b/utils/sane-backends/files/saned.xinetd
new file mode 100644 (file)
index 0000000..bc4dff8
--- /dev/null
@@ -0,0 +1,15 @@
+# default: off
+# description: The saned provides scanner service via the network.  \
+#      Applications like kooka, xsane or xscanimage can use the remote \
+#      scanner. 
+service sane-port
+{
+       socket_type = stream
+       port        = 6566
+       wait        = no
+       user        = root
+#      user        = saned
+       group       = scanner
+       server      = /usr/sbin/saned
+       disable     = yes
+}
diff --git a/utils/sane-backends/files/usr/sbin/saned b/utils/sane-backends/files/usr/sbin/saned
deleted file mode 100755 (executable)
index 7114926..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-#!/bin/sh
-
-usblp_driver="/sys/bus/usb/drivers/usblp"
-
-inuse=""
-if [ -e /sys/bus/usb/devices ]; then
-       for usbdev_driver in /sys/bus/usb/devices/*/driver; do
-               [ -e "$usbdev_driver" ] || continue
-               [ "$(readlink -f "$usbdev_driver")" = "$usblp_driver" ] || continue
-               usbdev="${usbdev_driver%/*}"
-               inuse="$inuse ${usbdev##*/}"
-       done
-fi
-
-/usr/lib/sane/saned "$@"
-err=$?
-
-for usbdev in $inuse; do
-       [ -e "/sys/bus/usb/devices/$usbdev/driver" ] && continue
-       logger -t saned "binding device $usbdev back to usblp..."
-       printf '%s' "$usbdev" > "$usblp_driver/bind"
-done
-
-exit $err
index 5bbf9cdf67961aa0a3ebe9736da98b2def9966d1..0a8f2a883da17f9015dac6d6a1d370b2de79f6ed 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile.in
 +++ b/Makefile.in
-@@ -423,7 +423,7 @@ target_alias = @target_alias@
+@@ -442,7 +442,7 @@ target_alias = @target_alias@
  top_build_prefix = @top_build_prefix@
  top_builddir = @top_builddir@
  top_srcdir = @top_srcdir@
diff --git a/utils/sane-backends/patches/031-fix_uclibc.patch b/utils/sane-backends/patches/031-fix_uclibc.patch
deleted file mode 100644 (file)
index 5993b27..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -280,6 +280,9 @@ AS_IF([test x != x$ALLOCA],
-       [LTALLOCA=`echo "$ALLOCA" | sed 's/\.o$//; s/\.obj$//'`.lo])
- AC_SUBST(LTALLOCA)
-+dnl Check mkostemp (missing in uclibc)
-+AC_CHECK_FUNC(mkostemp)
-+
- dnl Define SOCKET_LIB, NSL_LIB, BIND_LIB, and RESOLV_LIB  when required 
- dnl for functions we use.
- AC_CHECK_FUNC(gethostbyaddr,, [AC_CHECK_LIB(bind, gethostbyaddr, BIND_LIB="-lbind")])
---- a/include/sane/config.h.in
-+++ b/include/sane/config.h.in
-@@ -229,6 +229,9 @@
- /* Define to 1 if you have the `mkdir' function. */
- #undef HAVE_MKDIR
-+/* Define to 1 if you have a working `mkostemp' function. */
-+#undef HAVE_MKOSTEMP
-+
- /* Define to 1 if you have a working `mmap' system call. */
- #undef HAVE_MMAP
diff --git a/utils/sane-backends/patches/050-remove_linked_libs_for_unused_preload.patch b/utils/sane-backends/patches/050-remove_linked_libs_for_unused_preload.patch
deleted file mode 100644 (file)
index 5a4b9de..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/backend/Makefile.am
-+++ b/backend/Makefile.am
-@@ -1122,7 +1122,7 @@ EXTRA_DIST += dll.aliases
- nodist_libsane_la_SOURCES =  dll-s.c
- libsane_la_CPPFLAGS = $(AM_CPPFLAGS) -DBACKEND_NAME=dll
- libsane_la_LDFLAGS = $(DIST_LIBS_LDFLAGS)
--libsane_la_LIBADD = $(COMMON_LIBS) $(PRELOADABLE_BACKENDS_ENABLED) libdll_preload.la sane_strstatus.lo ../sanei/sanei_init_debug.lo ../sanei/sanei_constrain_value.lo ../sanei/sanei_config.lo ../sanei/sanei_config2.lo ../sanei/sanei_usb.lo ../sanei/sanei_scsi.lo ../sanei/sanei_pv8630.lo ../sanei/sanei_pp.lo ../sanei/sanei_thread.lo  ../sanei/sanei_lm983x.lo ../sanei/sanei_access.lo ../sanei/sanei_net.lo ../sanei/sanei_wire.lo ../sanei/sanei_codec_bin.lo ../sanei/sanei_pa4s2.lo ../sanei/sanei_ab306.lo ../sanei/sanei_pio.lo ../sanei/sanei_tcp.lo ../sanei/sanei_udp.lo ../sanei/sanei_magic.lo $(DL_LIBS) $(LIBV4L_LIBS) $(MATH_LIB) $(IEEE1284_LIBS) $(TIFF_LIBS) $(JPEG_LIBS) $(GPHOTO2_LIBS) $(SOCKET_LIBS) $(USB_LIBS) $(AVAHI_LIBS) $(SCSI_LIBS) $(PTHREAD_LIBS) $(RESMGR_LIBS)
-+libsane_la_LIBADD = $(COMMON_LIBS) $(PRELOADABLE_BACKENDS_ENABLED) libdll_preload.la sane_strstatus.lo ../sanei/sanei_init_debug.lo ../sanei/sanei_constrain_value.lo ../sanei/sanei_config.lo ../sanei/sanei_config2.lo ../sanei/sanei_usb.lo ../sanei/sanei_scsi.lo ../sanei/sanei_pv8630.lo ../sanei/sanei_pp.lo ../sanei/sanei_thread.lo  ../sanei/sanei_lm983x.lo ../sanei/sanei_access.lo ../sanei/sanei_net.lo ../sanei/sanei_wire.lo ../sanei/sanei_codec_bin.lo ../sanei/sanei_pa4s2.lo ../sanei/sanei_ab306.lo ../sanei/sanei_pio.lo ../sanei/sanei_tcp.lo ../sanei/sanei_udp.lo ../sanei/sanei_magic.lo $(DL_LIBS) $(MATH_LIB) $(IEEE1284_LIBS) $(SOCKET_LIBS) $(USB_LIBS) $(PTHREAD_LIBS) $(RESMGR_LIBS)
- # WARNING: Automake is getting this wrong so have to do it ourselves.
- libsane_la_DEPENDENCIES = $(COMMON_LIBS) $(PRELOADABLE_BACKENDS_ENABLED) libdll_preload.la sane_strstatus.lo ../sanei/sanei_init_debug.lo ../sanei/sanei_constrain_value.lo ../sanei/sanei_config.lo ../sanei/sanei_config2.lo ../sanei/sanei_usb.lo ../sanei/sanei_scsi.lo ../sanei/sanei_pv8630.lo ../sanei/sanei_pp.lo ../sanei/sanei_thread.lo  ../sanei/sanei_lm983x.lo ../sanei/sanei_access.lo ../sanei/sanei_net.lo ../sanei/sanei_wire.lo ../sanei/sanei_codec_bin.lo ../sanei/sanei_pa4s2.lo ../sanei/sanei_ab306.lo ../sanei/sanei_pio.lo ../sanei/sanei_tcp.lo ../sanei/sanei_udp.lo ../sanei/sanei_magic.lo $(SANEI_SANEI_JPEG_LO)
---- a/backend/Makefile.in
-+++ b/backend/Makefile.in
-@@ -2757,7 +2757,7 @@ libsane_dll_la_LIBADD = $(COMMON_LIBS) l
- nodist_libsane_la_SOURCES = dll-s.c
- libsane_la_CPPFLAGS = $(AM_CPPFLAGS) -DBACKEND_NAME=dll
- libsane_la_LDFLAGS = $(DIST_LIBS_LDFLAGS)
--libsane_la_LIBADD = $(COMMON_LIBS) $(PRELOADABLE_BACKENDS_ENABLED) libdll_preload.la sane_strstatus.lo ../sanei/sanei_init_debug.lo ../sanei/sanei_constrain_value.lo ../sanei/sanei_config.lo ../sanei/sanei_config2.lo ../sanei/sanei_usb.lo ../sanei/sanei_scsi.lo ../sanei/sanei_pv8630.lo ../sanei/sanei_pp.lo ../sanei/sanei_thread.lo  ../sanei/sanei_lm983x.lo ../sanei/sanei_access.lo ../sanei/sanei_net.lo ../sanei/sanei_wire.lo ../sanei/sanei_codec_bin.lo ../sanei/sanei_pa4s2.lo ../sanei/sanei_ab306.lo ../sanei/sanei_pio.lo ../sanei/sanei_tcp.lo ../sanei/sanei_udp.lo ../sanei/sanei_magic.lo $(DL_LIBS) $(LIBV4L_LIBS) $(MATH_LIB) $(IEEE1284_LIBS) $(TIFF_LIBS) $(JPEG_LIBS) $(GPHOTO2_LIBS) $(SOCKET_LIBS) $(USB_LIBS) $(AVAHI_LIBS) $(SCSI_LIBS) $(PTHREAD_LIBS) $(RESMGR_LIBS)
-+libsane_la_LIBADD = $(COMMON_LIBS) $(PRELOADABLE_BACKENDS_ENABLED) libdll_preload.la sane_strstatus.lo ../sanei/sanei_init_debug.lo ../sanei/sanei_constrain_value.lo ../sanei/sanei_config.lo ../sanei/sanei_config2.lo ../sanei/sanei_usb.lo ../sanei/sanei_scsi.lo ../sanei/sanei_pv8630.lo ../sanei/sanei_pp.lo ../sanei/sanei_thread.lo  ../sanei/sanei_lm983x.lo ../sanei/sanei_access.lo ../sanei/sanei_net.lo ../sanei/sanei_wire.lo ../sanei/sanei_codec_bin.lo ../sanei/sanei_pa4s2.lo ../sanei/sanei_ab306.lo ../sanei/sanei_pio.lo ../sanei/sanei_tcp.lo ../sanei/sanei_udp.lo ../sanei/sanei_magic.lo $(DL_LIBS) $(MATH_LIB) $(IEEE1284_LIBS) $(SOCKET_LIBS) $(USB_LIBS) $(PTHREAD_LIBS) $(RESMGR_LIBS)
- # WARNING: Automake is getting this wrong so have to do it ourselves.
- libsane_la_DEPENDENCIES = $(COMMON_LIBS) $(PRELOADABLE_BACKENDS_ENABLED) libdll_preload.la sane_strstatus.lo ../sanei/sanei_init_debug.lo ../sanei/sanei_constrain_value.lo ../sanei/sanei_config.lo ../sanei/sanei_config2.lo ../sanei/sanei_usb.lo ../sanei/sanei_scsi.lo ../sanei/sanei_pv8630.lo ../sanei/sanei_pp.lo ../sanei/sanei_thread.lo  ../sanei/sanei_lm983x.lo ../sanei/sanei_access.lo ../sanei/sanei_net.lo ../sanei/sanei_wire.lo ../sanei/sanei_codec_bin.lo ../sanei/sanei_pa4s2.lo ../sanei/sanei_ab306.lo ../sanei/sanei_pio.lo ../sanei/sanei_tcp.lo ../sanei/sanei_udp.lo ../sanei/sanei_magic.lo $(SANEI_SANEI_JPEG_LO)