boost: Remove several host libraries
authorRosen Penev <rosenp@gmail.com>
Sat, 5 Oct 2019 23:59:41 +0000 (16:59 -0700)
committerRosen Penev <rosenp@gmail.com>
Sun, 17 Nov 2019 02:13:52 +0000 (18:13 -0800)
The facebook people have been working on removing Boost dependencies from
their projects. This is the current state.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
(cherry-picked from ddd4109c1cc87193f2fd04eda1adb0886226fa67)

libs/boost/Makefile

index 9b2891df6ef3fb98c0d75be8976bc7aeb9f0d72a..90518c17a1e58969cc6a4391ee86a1a45e972631 100644 (file)
@@ -13,7 +13,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=boost
 PKG_VERSION:=1.71.0
 PKG_SOURCE_VERSION:=1_71_0
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_SOURCE_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)/$(PKG_NAME)/$(PKG_VERSION) https://dl.bintray.com/boostorg/release/$(PKG_VERSION)/source/
@@ -367,7 +367,7 @@ define Host/Compile
 
        ( cd $(HOST_BUILD_DIR) ; \
                ./bootstrap.sh --prefix=$(STAGING_DIR_HOSTPKG) \
-                       --with-libraries=atomic,context,date_time,filesystem,headers,program_options,regex,system,thread ;\
+                       --with-libraries=context,filesystem,program_options,regex,system ;\
                ./b2 --ignore-site-config install )
 endef