python,python3: Move python-config to $(STAGING_DIR)/host
authorJeffery To <jeffery.to@gmail.com>
Sun, 9 Jun 2019 06:05:55 +0000 (14:05 +0800)
committerJeffery To <jeffery.to@gmail.com>
Mon, 10 Jun 2019 12:33:06 +0000 (20:33 +0800)
Build/InstallDev is passed a second argument, a path where host binaries
should be placed (ultimately $(STAGING_DIR)/host).

This change moves python[3]-config to that directory.

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
lang/python/python/Makefile
lang/python/python/files/python-config.in
lang/python/python3/Makefile

index 9aea532b0793ed4435f4193b44b07af6d1e70f84..3bf5cbacdda180de500ce556dc1b385d871a5503 100644 (file)
@@ -205,7 +205,7 @@ endef
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include $(1)/usr/lib $(1)/usr/lib/pkgconfig
-       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_DIR) $(2)/bin
        $(INSTALL_DIR) $(1)/usr/lib/python$(PYTHON_VERSION)-openwrt
        $(CP) \
                $(PKG_INSTALL_DIR)/usr/include/python$(PYTHON_VERSION) \
@@ -219,10 +219,11 @@ define Build/InstallDev
                $(1)/usr/lib/pkgconfig
        $(INSTALL_BIN) \
                ./files/python-config.in \
-               $(1)/usr/bin/python$(PYTHON_VERSION)-config
+               $(2)/bin/python$(PYTHON_VERSION)-config
        $(SED) \
                's|@EXENAME@|$(HOST_PYTHON_DIR)/bin/python$(PYTHON_VERSION)|' \
-               $(1)/usr/bin/python$(PYTHON_VERSION)-config
+               -e 's|@TARGET_PREFIX@|$(PYTHON_DIR)|' \
+               $(2)/bin/python$(PYTHON_VERSION)-config
        $(CP) \
                $(PKG_INSTALL_DIR)/usr/lib/python$(PYTHON_VERSION)/_sysconfigdata.py \
                $(1)/usr/lib/python$(PYTHON_VERSION)-openwrt/_sysconfigdatatarget.py
index 46f6c9cd4aefff9b6de0a0f66d854a0a99930d14..c4a9c27adfcb2c480159972a6a4acc4bb8ab7b8b 100644 (file)
@@ -8,8 +8,7 @@ from distutils import sysconfig
 # start changes
 host_prefix = sysconfig.PREFIX
 
-target_bin_dir = os.path.dirname(os.path.abspath(__file__))
-target_prefix = os.path.normpath(os.path.join(target_bin_dir, '..'))
+target_prefix = '@TARGET_PREFIX@'
 
 target_data_dir = os.path.join(target_prefix, 'lib', 'python' + sysconfig.get_config_var('VERSION') + '-openwrt')
 sys.path.append(target_data_dir)
index 11ee77f0965b372d7dbf000bdcd57e456f274a11..34ba31fb0b95b10141d88f48ecf378f7ecce6555 100644 (file)
@@ -209,7 +209,7 @@ endef
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include $(1)/usr/lib $(1)/usr/lib/pkgconfig
-       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_DIR) $(2)/bin
        $(CP) \
                $(PKG_INSTALL_DIR)/usr/include/python$(PYTHON_VERSION) \
                $(1)/usr/include/
@@ -222,7 +222,10 @@ define Build/InstallDev
                $(1)/usr/lib/pkgconfig
        $(INSTALL_BIN) \
                $(PKG_INSTALL_DIR)/usr/bin/python$(PYTHON_VERSION)-config \
-               $(1)/usr/bin/
+               $(2)/bin/
+       $(SED) \
+               's|^prefix_real=.*$$$$|prefix_real="$(PYTHON3_DIR)"|' \
+               $(2)/bin/python$(PYTHON_VERSION)-config
 endef
 
 PYTHON3_BASE_LIB_FILES:= \