projects
/
feed
/
packages.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
93b34d4
)
vim: install vimdiff symlink for vim-full
author
Sergio E. Nemirowski
<sergio@outerface.net>
Wed, 5 May 2021 18:39:56 +0000
(21:39 +0300)
committer
Rosen Penev
<rosenp@gmail.com>
Thu, 6 May 2021 21:31:50 +0000
(14:31 -0700)
vim-full comes with diff feature
Signed-off-by: Sergio E. Nemirowski <sergio@outerface.net>
utils/vim/Makefile
patch
|
blob
|
history
diff --git
a/utils/vim/Makefile
b/utils/vim/Makefile
index da2e376304a8c046529b15a328205a9ea8d62957..bf41826870943ca5bb4c2ef34a9afe0a5f52a7fe 100644
(file)
--- a/
utils/vim/Makefile
+++ b/
utils/vim/Makefile
@@
-9,7
+9,7
@@
include $(TOPDIR)/rules.mk
PKG_NAME:=vim
PKG_VERSION:=8.2
-PKG_RELEASE:=
3
+PKG_RELEASE:=
4
VIMVER:=82
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@
-221,6
+221,7
@@
define Package/vim-full/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/vim_normal $(1)/usr/bin/vim
$(INSTALL_DIR) $(1)/usr/share/vim
+ $(LN) vim $(1)/usr/bin/vimdiff
$(INSTALL_CONF) ./files/vimrc.full $(1)/usr/share/vim/vimrc
endef