ucode: another fix for host installation
authorFelix Fietkau <nbd@nbd.name>
Fri, 20 Sep 2024 09:23:24 +0000 (11:23 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 20 Sep 2024 20:21:03 +0000 (22:21 +0200)
The previous host installation fix accidentally moved the rpath settings
out of CMAKE_HOST_OPTIONS and into CMAKE_OPTIONS.

Fixes: ae42ecaad4e7 ("ucode: fix host installation")
Signed-off-by: Felix Fietkau <nbd@nbd.name>
(cherry picked from commit 2ee1392e094f9b6fdb2a759e2e29fa203b61e066)

package/utils/ucode/Makefile

index 7fc5e9b07136418b1814c24430e2347c511b1cb4..b00dcf7572279f6ba12151091f252b71e294539a 100644 (file)
@@ -26,7 +26,9 @@ include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/cmake.mk
 
 CMAKE_OPTIONS += \
-       -DSOVERSION=$(PKG_ABI_VERSION) \
+       -DSOVERSION=$(PKG_ABI_VERSION)
+
+CMAKE_HOST_OPTIONS += \
        -DCMAKE_SKIP_RPATH=FALSE \
        -DCMAKE_INSTALL_RPATH="${STAGING_DIR_HOSTPKG}/lib"