open-plc-utils: fix compilation with GCC10
authorRosen Penev <rosenp@gmail.com>
Wed, 1 Jul 2020 01:49:41 +0000 (18:49 -0700)
committerRosen Penev <rosenp@gmail.com>
Wed, 1 Jul 2020 02:44:38 +0000 (19:44 -0700)
Signed-off-by: Rosen Penev <rosenp@gmail.com>
utils/open-plc-utils/Makefile
utils/open-plc-utils/patches/010-gcc10.patch [new file with mode: 0644]

index d9a0d9fa877cdb3cbd063c8ab86298846d63e323..166e7537a00326211768e5bea0afda5a1fa61a5c 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=open-plc-utils
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/qca/open-plc-utils.git
diff --git a/utils/open-plc-utils/patches/010-gcc10.patch b/utils/open-plc-utils/patches/010-gcc10.patch
new file mode 100644 (file)
index 0000000..957874f
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/plc/plc.h
++++ b/plc/plc.h
+@@ -498,7 +498,7 @@ struct __packed plcproperty
+       uint8_t DATA_BUFFER [128];
+ }
+-plcproperty;
++extern plcproperty;
+ #ifndef __GNUC__
+ #pragma pack (pop)